diff mbox series

[bug#47499] Update waybar

Message ID 6b52af4f96771757e24047262158fcaf@dismail.de
State Accepted
Headers show
Series [bug#47499] Update waybar | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

ashish.is--- via Guix-patches" via April 1, 2021, 6:09 a.m. UTC
Thanks for your comments, I tested new version with different configurations, look's fine.

This patch for delete fmt-6 and spdlog-1.7, because this packages is not needs.


March 31, 2021 2:33 PM, "Efraim Flashner" <efraim@flashner.co.il> wrote:

> Thanks for your patch. The commit message can use a bit more
> information so it's easy to follow what happened by just reading it.
> 
> gnu: waybar: Update to 0.9.5.
> 
> * gnu/packages/wm.scm (waybar): Update to 0.9.5.
> [inputs]: Replace fmt-6 with fmt, spdlog-1.7 with spdlog.
> 
> Also, if this is the last package which needs fmt-6 and spdlog-1.7 those
> can also be removed as part of this commit.
> 
> I don't run sway myself, does the new version work with the updated
> dependencies?
> 
> On Tue, Mar 30, 2021 at 11:31:17AM +0000, pricly_yellow--- via Guix-patches via wrote:
> 
>> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
>> index 6105a98f14..96e1527d5c 100644
>> --- a/gnu/packages/wm.scm
>> +++ b/gnu/packages/wm.scm
>> @@ -1569,7 +1569,7 @@ modules for building a Wayland compositor.")
>> (define-public waybar
>> (package
>> (name "waybar")
>> - (version "0.9.4")
>> + (version "0.9.5")
>> (source
>> (origin
>> (method git-fetch)
>> @@ -1578,10 +1578,10 @@ modules for building a Wayland compositor.")
>> (commit version)))
>> (file-name (git-file-name name version))
>> (sha256
>> - (base32 "038vnma7y7z81caywp45yr364bc1aq8d01j5vycyiyfv33nm76fy"))))
>> + (base32 "1kzrgqaclfk6gcwhknxn28xl74gm5swipgn8kk8avacb4nsw1l9q"))))
>> (build-system meson-build-system)
>> (inputs `(("date" ,date)
>> - ("fmt" ,fmt-6)
>> + ("fmt" ,fmt)
>> ("gtk-layer-shell" ,gtk-layer-shell)
>> ("gtkmm" ,gtkmm)
>> ("jsoncpp" ,jsoncpp)
>> @@ -1590,7 +1590,7 @@ modules for building a Wayland compositor.")
>> ("libmpdclent" ,libmpdclient)
>> ("libnl" ,libnl)
>> ("pulseaudio" ,pulseaudio)
>> - ("spdlog" ,spdlog-1.7)
>> + ("spdlog" ,spdlog)
>> ("wayland" ,wayland)))
>> (native-inputs
>> `(("gcc" ,gcc-8) ; for #include <filesystem>
> 
> --
> Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted

Comments

Efraim Flashner April 1, 2021, 7:53 a.m. UTC | #1
On Thu, Apr 01, 2021 at 06:09:52AM +0000, pricly_yellow@dismail.de wrote:
> Thanks for your comments, I tested new version with different configurations, look's fine.
> 
> This patch for delete fmt-6 and spdlog-1.7, because this packages is not needs.

Thanks. Patch applied!

> diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
> index af02fd91a9..4662a1e717 100644
> --- a/gnu/packages/pretty-print.scm
> +++ b/gnu/packages/pretty-print.scm
> @@ -189,19 +189,6 @@ to @code{IOStreams}.")
> ;; The library is bsd-2, but documentation and tests include other licenses.
> (license (list bsd-2 bsd-3 psfl))))
> 
> -(define-public fmt-6
> - (package
> - (inherit fmt)
> - (name "fmt")
> - (version "6.2.1")
> - (source
> - (origin
> - (method url-fetch)
> - (uri (string-append "https://github.com/fmtlib/fmt/releases/download"
> - version "/fmt-" version ".zip"))
> - (sha256
> - (base32 "06l8g59frbsbwj15kg6x2bbn6p8yidh6wzsigdhbdjncvm1agzll"))))))
> -
> (define-public source-highlight
> (package
> (name "source-highlight")
> 
> diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
> index b879fecebc..6a4975e435 100644
> --- a/gnu/packages/logging.scm
> +++ b/gnu/packages/logging.scm
> @@ -214,19 +214,3 @@ library.")
> ;; spdlog is under Expat license, but the bundled fmt library in
> ;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
> (license (list license:expat license:bsd-2))))
> -
> -(define-public spdlog-1.7
> - (package
> - (inherit spdlog)
> - (name "spdlog")
> - (version "1.7.0")
> - (source
> - (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/gabime/spdlog")
> - (commit (string-append "v" version))))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> - "1ryaa22ppj60461hcdb8nk7jwj84arp4iw4lyw594py92g4vnx3j"))))))
> 
> March 31, 2021 2:33 PM, "Efraim Flashner" <efraim@flashner.co.il> wrote:
> 
> > Thanks for your patch. The commit message can use a bit more
> > information so it's easy to follow what happened by just reading it.
> > 
> > gnu: waybar: Update to 0.9.5.
> > 
> > * gnu/packages/wm.scm (waybar): Update to 0.9.5.
> > [inputs]: Replace fmt-6 with fmt, spdlog-1.7 with spdlog.
> > 
> > Also, if this is the last package which needs fmt-6 and spdlog-1.7 those
> > can also be removed as part of this commit.
> > 
> > I don't run sway myself, does the new version work with the updated
> > dependencies?
> > 
> > On Tue, Mar 30, 2021 at 11:31:17AM +0000, pricly_yellow--- via Guix-patches via wrote:
> > 
> >> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> >> index 6105a98f14..96e1527d5c 100644
> >> --- a/gnu/packages/wm.scm
> >> +++ b/gnu/packages/wm.scm
> >> @@ -1569,7 +1569,7 @@ modules for building a Wayland compositor.")
> >> (define-public waybar
> >> (package
> >> (name "waybar")
> >> - (version "0.9.4")
> >> + (version "0.9.5")
> >> (source
> >> (origin
> >> (method git-fetch)
> >> @@ -1578,10 +1578,10 @@ modules for building a Wayland compositor.")
> >> (commit version)))
> >> (file-name (git-file-name name version))
> >> (sha256
> >> - (base32 "038vnma7y7z81caywp45yr364bc1aq8d01j5vycyiyfv33nm76fy"))))
> >> + (base32 "1kzrgqaclfk6gcwhknxn28xl74gm5swipgn8kk8avacb4nsw1l9q"))))
> >> (build-system meson-build-system)
> >> (inputs `(("date" ,date)
> >> - ("fmt" ,fmt-6)
> >> + ("fmt" ,fmt)
> >> ("gtk-layer-shell" ,gtk-layer-shell)
> >> ("gtkmm" ,gtkmm)
> >> ("jsoncpp" ,jsoncpp)
> >> @@ -1590,7 +1590,7 @@ modules for building a Wayland compositor.")
> >> ("libmpdclent" ,libmpdclient)
> >> ("libnl" ,libnl)
> >> ("pulseaudio" ,pulseaudio)
> >> - ("spdlog" ,spdlog-1.7)
> >> + ("spdlog" ,spdlog)
> >> ("wayland" ,wayland)))
> >> (native-inputs
> >> `(("gcc" ,gcc-8) ; for #include <filesystem>
> >
Efraim Flashner April 1, 2021, 7:54 a.m. UTC | #2
Forgot to close the bug.
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index af02fd91a9..4662a1e717 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -189,19 +189,6 @@  to @code{IOStreams}.")
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))

-(define-public fmt-6
- (package
- (inherit fmt)
- (name "fmt")
- (version "6.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/fmtlib/fmt/releases/download"
- version "/fmt-" version ".zip"))
- (sha256
- (base32 "06l8g59frbsbwj15kg6x2bbn6p8yidh6wzsigdhbdjncvm1agzll"))))))
-
(define-public source-highlight
(package
(name "source-highlight")

diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index b879fecebc..6a4975e435 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -214,19 +214,3 @@  library.")
;; spdlog is under Expat license, but the bundled fmt library in
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
-
-(define-public spdlog-1.7
- (package
- (inherit spdlog)
- (name "spdlog")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gabime/spdlog")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ryaa22ppj60461hcdb8nk7jwj84arp4iw4lyw594py92g4vnx3j"))))))