diff mbox series

[bug#69011] gnu: Add python-pdbfixer.

Message ID 6b3d0b29311e02f801f0990ccb88033763f00e56.1707560088.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#69011] gnu: Add python-pdbfixer. | expand

Commit Message

nafkhamdc Feb. 10, 2024, 10:14 a.m. UTC
* gnu/packages/bioinformatics.scm (python-pdbfixer): New variable.

Change-Id: I2894a08ab3eed463f052b9df6372d4016b718d1a
---
 gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: 10dba10fd6551ab480a38d00301e6f102def674d
prerequisite-patch-id: 3a59afadab83198b19921e19197e26925523b4a3
prerequisite-patch-id: 116b12264d1713957eef349460a71f04b0757a9e

Comments

Ricardo Wurmus Feb. 10, 2024, 10:21 a.m. UTC | #1
Thanks for the patch.  I’ve applied it and pushed with commit
ca4c9062c4a04a3550fdcf67cb2b41daa13627d8.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 56709c0332..2c1917be95 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2244,6 +2244,37 @@  (define-public python-parabam
 defined rule on an input file.")
     (license license:gpl3)))
 
+(define-public python-pdbfixer
+  (package
+    (name "python-pdbfixer")
+    (version "1.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openmm/pdbfixer")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zjhb19q5dclkwvzh8n29p31n1vzkhlmmzwqllimi89jsis1cx35"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags '(list "-k"
+                          ;; These tests fail because they require internet access.
+                          (string-append "not test_build_and_simulate.py"
+                                         " and not test_cli.py"
+                                         " and not test_mutate.py"))))
+    (propagated-inputs (list python-numpy openmm))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/openmm/pdbfixer")
+    (synopsis "Application for fixing problems in Protein Data Bank")
+    (description
+     "PDBFixer is designed to rectify issues in Protein Data Bank files.
+Its intuitive interface simplifies the process of resolving problems
+encountered in PDB files prior to simulation tasks.")
+    (license license:expat)))
+
 (define-public python-peaks2utr
   (package
     (name "python-peaks2utr")