diff mbox series

[bug#42457] gnu: knights: Fix build.

Message ID 6b0f84d5-7440-5829-cc78-49b30d35ad88@gmail.com
State Accepted
Headers show
Series [bug#42457] gnu: knights: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 28, 2020, 4:05 a.m. UTC
Attached.

On 7/25/20 6:16 AM, Oleg Pykhalov wrote:
> Hi,
>
> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>
>> * gnu/packages/games.scm (knights):
>> [make-flags] add "CXXFLAGS=-lpthread"
>> ---
>> gnu/packages/games.scm | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
>> index cff1c0af99..dc0511e55a 100644
>> --- a/gnu/packages/games.scm
>> +++ b/gnu/packages/games.scm
>> @@ -1366,7 +1366,8 @@ built-in level editor.")
>> (build-system gnu-build-system)
>> (arguments
>> '(#:make-flags
>> - (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
>> + (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
>> + "CXXFLAGS=-lpthread")
>> #:phases
>> (modify-phases %standard-phases
>> ;; No configure script.
> This patch looks broken for me, could you resend it, please?
>
> Thanks,
> Oleg.

Comments

Oleg Pykhalov July 28, 2020, 6:13 p.m. UTC | #1
Hi,

[…]

> * gnu/packages/games.scm (knights):
> [make-flags] add "CXXFLAGS=-lpthread"

Rather:
* gnu/packages/games.scm (knights)[arguments]<#:make-flags>: Add
"CXXFLAGS=-lpthread".

> ---
>  gnu/packages/games.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index cff1c0af99..dc0511e55a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1366,7 +1366,8 @@ built-in level editor.")
>      (build-system gnu-build-system)
>      (arguments
>       '(#:make-flags
> -       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> +       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
> +	     "CXXFLAGS=-lpthread")

^
Please, use spaces instead of tabs. ;-)

>         #:phases
>         (modify-phases %standard-phases
>           ;; No configure script.

Pushed to master with mentioned changes.

Oleg.
diff mbox series

Patch

From 6608c7ce9057a9bc38df723b38523aad5c05d41e Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Sun, 5 Apr 2020 20:47:02 -0600
Subject: [PATCH 1/1] gnu: knights: Fix build.

* gnu/packages/games.scm (knights):
[make-flags] add "CXXFLAGS=-lpthread"
---
 gnu/packages/games.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cff1c0af99..dc0511e55a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1366,7 +1366,8 @@  built-in level editor.")
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags
-       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+	     "CXXFLAGS=-lpthread")
        #:phases
        (modify-phases %standard-phases
          ;; No configure script.
-- 
2.27.0