diff mbox series

[bug#66505] gnu: Add fast-downward.

Message ID 6af9732e8aefc27bea7de734242609a88ff4dd32.1697134721.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#66505] gnu: Add fast-downward. | expand

Commit Message

Liliana Marie Prikler Oct. 12, 2023, 5:26 p.m. UTC
* gnu/packages/maths.scm (fast-downward): New variable.
---
 gnu/packages/maths.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)


base-commit: 1328c4cca531318e3ed90c6aecb522a5b22a4bcc
prerequisite-patch-id: c1e8930b4fa8edf38130d45c5205a019b6e26dc7
prerequisite-patch-id: 730b3b393d9502ebb6b8339f7ead9589cec71c6f
prerequisite-patch-id: 1fdb09d54aa0ba3082f9501119c9810a36b0c66a

Comments

Ludovic Courtès Oct. 14, 2023, 8:31 p.m. UTC | #1
Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/maths.scm (fast-downward): New variable.

LGTM! :-)
Liliana Marie Prikler Oct. 15, 2023, 10:30 a.m. UTC | #2
Am Samstag, dem 14.10.2023 um 22:31 +0200 schrieb Ludovic Courtès:
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/maths.scm (fast-downward): New variable.
> 
> LGTM! :-)
Thanks.

Pushed now.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9d157ae921..3ad3170b09 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3178,6 +3178,61 @@  (define-public opencascade-occt
                    ;; File src/NCollection/NCollection_StdAllocator.hxx:
                    license:public-domain))))
 
+(define-public fast-downward
+  (package
+    (name "fast-downward")
+    (version "23.06.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/aibasel/downward")
+                    (commit (string-append "release-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1xrgnvbkzkdf6srbrlsnf4qrgp0f1lkk7yxf34ynna0w49l468d4"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f        ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-driver
+            (lambda* (#:key outputs #:allow-other-keys)
+              (substitute* "driver/run_components.py"
+                ;; strip gratuitous "bin"
+                (("os\\.path\\.join\\((.*), \"bin\"\\)" all keep)
+                 (string-append "os.path.join(" keep ")")))))
+          (add-before 'configure 'chdir
+            (lambda _ (chdir "src")))
+          (replace 'install
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (dest (string-append out "/libexec/fast-downward"
+                                          "/builds/release")))
+                (mkdir-p dest)
+                (with-directory-excursion "bin"
+                  (install-file "downward" dest)
+                  (copy-recursively "translate"
+                                    (string-append dest "/translate"))))))
+          (add-after 'install 'install-driver
+            (lambda* (#:key outputs #:allow-other-keys)
+              (with-directory-excursion ".."
+                (let* ((out (assoc-ref outputs "out"))
+                       (bin (string-append out "/bin/fast-downward"))
+                       (dest (string-append out "/libexec/fast-downward")))
+                  (copy-recursively "driver"
+                                    (string-append dest "/driver"))
+                  (mkdir-p (dirname bin))
+                  (copy-file "fast-downward.py" bin)
+                  (wrap-program bin
+                    `("PYTHONPATH" prefix (,dest))))))))))
+    (inputs (list bash-minimal python))
+    (home-page "https://www.fast-downward.org/")
+    (synopsis "Domain-independant classical planning system")
+    (description "Fast Downward is a portfolio-based planning system that
+supports the propositional fragment of PDDL2.2.")
+    (license license:gpl3+)))
+
 (define-public gmsh
   (package
     (name "gmsh")