diff mbox series

[bug#63798] Fix Erlang package substitutions

Message ID 6aefc528753b5e46753ed8f70c5a062b9a1cd8ef.1685397780.git.wrobell@riseup.net
State New
Headers show
Series [bug#63798] Fix Erlang package substitutions | expand

Commit Message

wrobell May 29, 2023, 10:22 p.m. UTC
Both `dirname` and `basename` need to be substituted. There is no need
for `sed` substitution in Erlag 25.3.
---
 gnu/packages/erlang.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)


base-commit: 7b400e7f8751e6b0cc6e66d3f7ecfb7f5bd51309

Comments

wrobell June 20, 2023, 10:48 a.m. UTC | #1
I believe, the fix is required when I run my custom RabbitMQ package.

Also, some other user experiences the same issue

    https://lists.gnu.org/archive/html/guix-devel/2023-04/msg00003.html

Best regards,

w

--
https://mortgage.diy-labs.eu/
Nicolas Goaziou July 1, 2023, 10:07 a.m. UTC | #2
Hello,

wrobell <wrobell@riseup.net> writes:

> Both `dirname` and `basename` need to be substituted. There is no need
> for `sed` substitution in Erlag 25.3.

Applied, with a proper commit message. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 7564c2a560..b6e82e0109 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
 ;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 wrobell <wrobell@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -168,7 +169,8 @@  (define-public erlang
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (substitute* (string-append out "/bin/erl")
-                 (("sed") (which "sed"))))))
+                 (("basename") (which "basename"))
+                 (("dirname") (which "dirname"))))))
          (add-after 'install 'install-doc
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))