diff mbox series

[bug#71306,gnome-team] gnu: gtk: Fix build on i686-linux.

Message ID 6aa777e0ad96e8cb208b86c1e8450784b0e102e3.1717058246.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#71306,gnome-team] gnu: gtk: Fix build on i686-linux. | expand

Commit Message

Liliana Marie Prikler May 30, 2024, 8:25 a.m. UTC
* gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to
failures on i686-linux.
---
 gnu/packages/gtk.scm | 15 ++++++++++++++-
 1 file changed, 14 insertions(+), 1 deletion(-)


base-commit: 4b5b1fa8125c3055ddea36f37e0c5311489e1563

Comments

Maxim Cournoyer June 1, 2024, 3:04 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to
> failures on i686-linux.
> ---
>  gnu/packages/gtk.scm | 15 ++++++++++++++-
>  1 file changed, 14 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index d5777ae67b..1c78a969f6 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1235,7 +1235,20 @@ (define-public gtk
>                  ;; The inscription-markup.ui fails due to /etc/machine-id
>                  ;; related warnings (see:
>                  ;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
> -                (("[ \t]*'inscription-markup.ui',") ""))))
> +                (("[ \t]*'inscription-markup.ui',") ""))
> +              ;; XXX: These failures appear specific to i686 – investigate them.
> +              #$@(if (target-x86-32?)
> +                     #~((substitute* "testsuite/gsk/meson.build"
> +                          (("'empty-(fill|stroke)\\.node',") "")
> +                          (("'fill2?\\.node',") "")
> +                          (("'stroke\\.node',") "")
> +                          (("'fill-fractional-([a-z-]*)-nogl',") "")
> +                          (("\\[ 'path-special-cases' \\],") "")
> +                          (("\\[ '(path|curve)-special-cases' \\],") "")
> +                          (("\\[ 'path-private' \\],") ""))
> +                        (substitute* "testsuite/a11y/meson.build"
> +                           (("\\{ 'name': 'text(view)?' \\},") "")))
> +                    #~())))

Are you sure these are specific to i686 and not to 32 bit architectures
such as armhf also?
Liliana Marie Prikler June 1, 2024, 4:20 p.m. UTC | #2
Am Samstag, dem 01.06.2024 um 11:04 -0400 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section
> > dedicated to
> > failures on i686-linux.
> > ---
> >  gnu/packages/gtk.scm | 15 ++++++++++++++-
> >  1 file changed, 14 insertions(+), 1 deletion(-)
> > 
> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> > index d5777ae67b..1c78a969f6 100644
> > --- a/gnu/packages/gtk.scm
> > +++ b/gnu/packages/gtk.scm
> > @@ -1235,7 +1235,20 @@ (define-public gtk
> >                  ;; The inscription-markup.ui fails due to
> > /etc/machine-id
> >                  ;; related warnings (see:
> >                  ;;
> > https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
> > -                (("[ \t]*'inscription-markup.ui',") ""))))
> > +                (("[ \t]*'inscription-markup.ui',") ""))
> > +              ;; XXX: These failures appear specific to i686 –
> > investigate them.
> > +              #$@(if (target-x86-32?)
> > +                     #~((substitute* "testsuite/gsk/meson.build"
> > +                          (("'empty-(fill|stroke)\\.node',") "")
> > +                          (("'fill2?\\.node',") "")
> > +                          (("'stroke\\.node',") "")
> > +                          (("'fill-fractional-([a-z-]*)-nogl',")
> > "")
> > +                          (("\\[ 'path-special-cases' \\],") "")
> > +                          (("\\[ '(path|curve)-special-cases'
> > \\],") "")
> > +                          (("\\[ 'path-private' \\],") ""))
> > +                        (substitute* "testsuite/a11y/meson.build"
> > +                           (("\\{ 'name': 'text(view)?' \\},")
> > "")))
> > +                    #~())))
> 
> Are you sure these are specific to i686 and not to 32 bit
> architectures such as armhf also?
Well, I only tested it on x86-32.  If we see the same failures on
armhf, I can just update the predicate.

WDYT?
Maxim Cournoyer June 3, 2024, 12:10 p.m. UTC | #3
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 01.06.2024 um 11:04 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section
>> > dedicated to
>> > failures on i686-linux.

OK, let's do this!

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d5777ae67b..1c78a969f6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1235,7 +1235,20 @@  (define-public gtk
                 ;; The inscription-markup.ui fails due to /etc/machine-id
                 ;; related warnings (see:
                 ;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
-                (("[ \t]*'inscription-markup.ui',") ""))))
+                (("[ \t]*'inscription-markup.ui',") ""))
+              ;; XXX: These failures appear specific to i686 – investigate them.
+              #$@(if (target-x86-32?)
+                     #~((substitute* "testsuite/gsk/meson.build"
+                          (("'empty-(fill|stroke)\\.node',") "")
+                          (("'fill2?\\.node',") "")
+                          (("'stroke\\.node',") "")
+                          (("'fill-fractional-([a-z-]*)-nogl',") "")
+                          (("\\[ 'path-special-cases' \\],") "")
+                          (("\\[ '(path|curve)-special-cases' \\],") "")
+                          (("\\[ 'path-private' \\],") ""))
+                        (substitute* "testsuite/a11y/meson.build"
+                           (("\\{ 'name': 'text(view)?' \\},") "")))
+                    #~())))
           (add-before 'build 'set-cache
             (lambda _
               (setenv "XDG_CACHE_HOME" (getcwd))))