diff mbox series

[bug#66931] gnu: python-autograd: Update to 1.5.

Message ID 6aa182f99b9f49511cb812ae89fe06407a30108b.1699110430.git.felgru@posteo.net
State New
Headers show
Series [bug#66931] gnu: python-autograd: Update to 1.5. | expand

Commit Message

Felix Gruber Nov. 4, 2023, 3:07 p.m. UTC
* gnu/packages/machine-learning.scm (python-autograd): Update to 1.5.
  [build-system]: Use pyproject-build-system.
  [arguments]: Remove custom 'check phase.

Change-Id: Ic76510b94d268d5dba6e9b0e057fcfca125e424f
---
 gnu/packages/machine-learning.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)


base-commit: 9dcd8802f5bc472579f23a38dcf437f8a9ac976c

Comments

Ludovic Courtès Dec. 6, 2023, 10:08 p.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/machine-learning.scm (python-autograd): Update to 1.5.
>   [build-system]: Use pyproject-build-system.
>   [arguments]: Remove custom 'check phase.
>
> Change-Id: Ic76510b94d268d5dba6e9b0e057fcfca125e424f

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a84377e1eb..7518cd413a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1923,9 +1923,9 @@  (define-public python-cmaes
     (license license:expat)))
 
 (define-public python-autograd
-  (let* ((commit "442205dfefe407beffb33550846434baa90c4de7")
+  (let* ((commit "c6d81ce7eede6db801d4e9a92b27ec5d409d0eab")
          (revision "0")
-         (version (git-version "0.0.0" revision commit)))
+         (version (git-version "1.5" revision commit)))
     (package
       (name "python-autograd")
       (home-page "https://github.com/HIPS/autograd")
@@ -1936,19 +1936,14 @@  (define-public python-autograd
                       (commit commit)))
                 (sha256
                  (base32
-                  "189sv2xb0mwnjawa9z7mrgdglc1miaq93pnck26r28fi1jdwg0z4"))
+                  "04kljgydng42xlg044h6nbzxpban1ivd6jzb8ydkngfq88ppipfk"))
                 (file-name (git-file-name name version))))
       (version version)
-      (build-system python-build-system)
+      (build-system pyproject-build-system)
       (native-inputs
        (list python-nose python-pytest))
       (propagated-inputs
        (list python-future python-numpy))
-      (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (replace 'check
-                      (lambda _
-                        (invoke "py.test" "-v"))))))
       (synopsis "Efficiently computes derivatives of NumPy code")
       (description "Autograd can automatically differentiate native Python and
 NumPy code.  It can handle a large subset of Python's features, including loops,