diff mbox series

[bug#71347] gnu: Add emacs-org-timeblock.

Message ID 6a9f22becd6264c14b7fa63b3bd3a6c19bcb4433.1717437358.git.ichernyshovvv@gmail.com
State New
Headers show
Series [bug#71347] gnu: Add emacs-org-timeblock. | expand

Commit Message

Ilya Chernyshov June 3, 2024, 6 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-timeblock): New variable.

Change-Id: I7a5844bc11d263131b4e1d2fb23a223747c4f63c
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb
prerequisite-patch-id: fec8c38c077df9e314d4c220cc9314e3ec50d550

Comments

Andrew Tropin June 5, 2024, 9:20 a.m. UTC | #1
On 2024-06-04 01:00, Ilya Chernyshov wrote:

> * gnu/packages/emacs-xyz.scm (emacs-org-timeblock): New variable.
>
> Change-Id: I7a5844bc11d263131b4e1d2fb23a223747c4f63c
> ---
>  gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 2209169864..c15e99c9fc 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -23545,6 +23545,35 @@ (define-public emacs-org-recur
>  for defining recurring tasks and easily scheduling them.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-org-timeblock
> +  (let ((revision "0")
> +        (commit "b423b01712b9c25dff3e4203c7cde736225f62ef"))
> +    (package
> +      (name "emacs-org-timeblock")
> +      (version (git-version "0.2" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://github.com/ichernyshovvv/org-timeblock.git")
> +           (commit commit)))
> +         (sha256
> +          (base32 "1q0271nli4yw01rwybkzdlqcj8ivqwh5r70yv9x0qqwxa955c9k9"))
> +         (file-name (git-file-name name version))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list emacs-compat))
> +      (home-page "https://github.com/ichernyshovvv/org-timeblock")
> +      (synopsis
> +       "Schedule your day visually, using timeblocking technique inside Emacs")
> +      (description "The builtin orgmode package for viewing tasks or events
> +for a particular day, org-agenda, does not help you to quickly understand,
> +where, for example, you have free time in your day or where you have overlapping
> +tasks. Just a list of tasks is not sufficient. This package is created to
> +fix this problem and provide some of the functionality that modern calendars
> +provide.")
> +      (license license:gpl3+))))
> +
>  (define-public emacs-org-super-agenda
>    (package
>      (name "emacs-org-super-agenda")
>
> base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb
> prerequisite-patch-id: fec8c38c077df9e314d4c220cc9314e3ec50d550

Hi Ilya!

You can use `guix lint` to see the recommendations for code formatting,
please run it next time before submitting the package.

--8<---------------cut here---------------start------------->8---
./pre-inst-env guix lint emacs-org-timeblock
gnu/packages/emacs-xyz.scm:23569:19: emacs-org-timeblock@0.2-0.b423b01: sentences in description should be followed by two spaces; possible infractions at 217, 257
gnu/packages/emacs-xyz.scm:23555:7: emacs-org-timeblock@0.2-0.b423b01: permanent redirect from https://github.com/ichernyshovvv/org-timeblock.git to https://github.com/ichernyshovvv/org-timeblock
--8<---------------cut here---------------end--------------->8---

I incorporated the suggestions from linter and pushed the changes as
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=6e1bd62d55

Thank you for the patch!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2209169864..c15e99c9fc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23545,6 +23545,35 @@  (define-public emacs-org-recur
 for defining recurring tasks and easily scheduling them.")
     (license license:gpl3+)))
 
+(define-public emacs-org-timeblock
+  (let ((revision "0")
+        (commit "b423b01712b9c25dff3e4203c7cde736225f62ef"))
+    (package
+      (name "emacs-org-timeblock")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/ichernyshovvv/org-timeblock.git")
+           (commit commit)))
+         (sha256
+          (base32 "1q0271nli4yw01rwybkzdlqcj8ivqwh5r70yv9x0qqwxa955c9k9"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-compat))
+      (home-page "https://github.com/ichernyshovvv/org-timeblock")
+      (synopsis
+       "Schedule your day visually, using timeblocking technique inside Emacs")
+      (description "The builtin orgmode package for viewing tasks or events
+for a particular day, org-agenda, does not help you to quickly understand,
+where, for example, you have free time in your day or where you have overlapping
+tasks. Just a list of tasks is not sufficient. This package is created to
+fix this problem and provide some of the functionality that modern calendars
+provide.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-super-agenda
   (package
     (name "emacs-org-super-agenda")