diff mbox series

[bug#70372,4/4] gnu: Add go-github-com-multiformats-go-multiaddr-dns.

Message ID 6a695dd0e3aa1c80c05ce6fdd034d42f349913d9.1713075150.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-multiformats-go-multiaddr-dns. | expand

Commit Message

Artyom V. Poptsov April 14, 2024, 6:33 a.m. UTC
* gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr-dns):
  New variable.

Change-Id: I6e81e9b4773cd97a5625661089f4ed35d2adba33
---
 gnu/packages/golang-web.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 7411acd2a2..59dd1e0a52 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1335,6 +1335,43 @@  (define-public go-github-com-multiformats-go-multiaddr-0.12
                              go-github-com-multiformats-go-multihash-0.2.3
                              go-golang-org-x-exp-2023))))
 
+(define-public go-github-com-multiformats-go-multiaddr-dns
+  (let ((commit "6e944aaa78597c34baa8d68a91c3ca236837760c")
+        (revision "0"))
+    (package
+      (name "go-github-com-multiformats-go-multiaddr-dns")
+      (version (git-version "0.3.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/multiformats/go-multiaddr-dns")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0ns3kxixl3kmwwdl1z9jawgns00jgmi76j9gbxk68ys8a5nyng5a"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/multiformats/go-multiaddr-dns"
+        #:go go-1.21
+        ;; TODO: Tests fail because they try to access the network.
+        #:tests? #f))
+      (propagated-inputs (list go-github-com-gxed-hashland-keccakpg
+                               go-github-com-miekg-dns
+                               go-github-com-minio-blake2b-simd
+                               go-github-com-minio-sha256-simd
+                               go-github-com-mr-tron-base58
+                               go-github-com-multiformats-go-multiaddr-0.12
+                               go-github-com-multiformats-go-varint
+                               go-github-com-spaolacci-murmur3
+                               go-golang-org-x-crypto))
+      (home-page "https://multiformats.io/multiaddr/")
+      (synopsis "Library and CLI tool for DNS multiaddr resolution")
+      (description
+       "Go library and CLI tool for /dns4, /dns6, /dnsaddr multiaddr resolution.")
+      (license license:expat))))
+
 (define-public go-github-com-multiformats-go-multiaddr-net
   ;; This commit is from <2018-10-01> and associated with GX package manager,
   ;; since that time the project has changed versing stile and GX is dropped.