diff mbox series

[bug#64362,1/3] gnu: Add python-nbt.

Message ID 6a3d5c55-d481-e3dc-f423-eb7f6c8313b9@disroot.org
State New
Headers show
Series gnu: Add mc2mt. | expand

Commit Message

Adam Faiz June 30, 2023, 9:21 a.m. UTC
From 8650c4e383b9cb3941db42227f69d2aa7decfb67 Mon Sep 17 00:00:00 2001
Message-Id: <8650c4e383b9cb3941db42227f69d2aa7decfb67.1688115598.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1688115598.git.adam.faiz@disroot.org>
References: <cover.1688115598.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 30 Jun 2023 16:33:28 +0800
Subject: [PATCH 1/3] gnu: Add python-nbt.

* gnu/packages/game-development.scm (python-nbt): New variable.
---
 gnu/packages/game-development.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1b93773b6d..9fcfe468ef 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -442,6 +442,23 @@  (define-public nml
 files) into @file{.grf} and/or @file{.nfo} files.")
     (license license:gpl2+)))
 
+(define-public python-nbt
+  (package
+    (name "python-nbt")
+    (version "1.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "NBT" version))
+            (sha256
+             (base32
+              "1i9ncrzy5zcfnxzkh2j31n9ayzxfncckzwa6fkz9vjq5fq9v4fys"))))
+    (build-system python-build-system)
+    (home-page "http://github.com/twoolie/NBT")
+    (synopsis "Named Binary Tag reader/writer")
+    (description "This library is a parser/writer for the NBT file format,
+and it's container the RegionFile.  It can inspect and edit Minecraft data files.")
+    (license license:expat)))
+
 (define-public python-sge
   (package
     (name "python-sge")