[bug#77006,2/3] gnu: Add python-flexparser.

Message ID 6a220f8fdefc8de120c9b70dbb9400913ec09ef2.1741938583.git.lars.bilke@ufz.de
State New
Headers
Series Update python-pint to 0.24.4 |

Commit Message

Lars Bilke March 14, 2025, 7:52 a.m. UTC
  * gnu/packages/python-xyz.scm (python-flexparser): New variable.

Change-Id: I93a33886285a736fa50c6e8ee66b7d34e61ced5c
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6a38332021..2ec476ba12 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2122,6 +2122,30 @@  (define-public python-flexcache
 expensive calculations.")
     (license license:bsd-3)))
 
+(define-public python-flexparser
+  (package
+    (name "python-flexparser")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flexparser" version))
+       (sha256
+        (base32 "1cpn5scxnxbd2jrnany4znzzn9im5h5gwr59bp62rglman89hv96"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-typing-extensions))
+    (native-inputs (list python-pytest
+                         python-pytest-cov
+                         python-pytest-mpl
+                         python-pytest-subtests
+                         python-setuptools
+                         python-setuptools-scm
+                         python-wheel))
+    (home-page "https://github.com/hgrecco/flexparser")
+    (synopsis "Parsing made fun ... using typing.")
+    (description "A typed parser.")
+    (license license:bsd-3)))
+
 (define-public python-pint
   (package
     (name "python-pint")