diff mbox series

[bug#51739,1/3] gnu: Add realmd.

Message ID 6_VxudlTY15fzm92EqTAhsKxRhhiHv2FfIhOjIXdIzf1Jt-G3s7rWMyxE_5SC0QyAt4logqsdA3y4_mruh9N6oez0lU_x0FpfX8JbUOtQJw=@protonmail.com
State Accepted
Headers show
Series [bug#51739,1/3] gnu: Add realmd. | expand

Commit Message

phodina Dec. 2, 2021, 7:13 p.m. UTC
Sorry I've lost signal and when connected again the mail client sent the reply without the patch.

Now it's attached properly.

Comments

Leo Famulari Dec. 2, 2021, 7:24 p.m. UTC | #1
On Thu, Dec 02, 2021 at 07:13:40PM +0000, phodina via Guix-patches via wrote:
> Subject: [PATCH v2] gnu: Add realmd.
> 
> * gnu/packages/admin.scm (realmd): New variable.

Thanks for fixing the issues I had mentioned.

> +         (add-before 'install 'fix-service
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             ;; Don't copy config file
> +             (substitute* "Makefile"
> +               ((".*/service/realmd-.*") "")))))))

Can you clarify what this does? It wasn't in earlier revisions of the
patch.
diff mbox series

Patch

From a488638672d7a4360743c2ba52474801a3fcdbc8 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Wed, 10 Nov 2021 03:53:37 +0100
Subject: [PATCH v2] gnu: Add realmd.

* gnu/packages/admin.scm (realmd): New variable.

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d24b068bd7..5e25a283e8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -128,6 +128,7 @@  (define-module (gnu packages admin)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages polkit)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
@@ -1533,6 +1534,55 @@  (define-public clusterssh
 over ssh connections.")
     (license license:gpl2+)))
 
+(define-public realmd
+  (package
+    (name "realmd")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/freedesktop/realmd")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1c6q2a86kk2f1akzc36nh52hfwsmmc0mbp6ayyjxj4zsyk9zx5bf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--with-systemd-unit-dir=no"
+                           "--with-systemd-journal=no"
+                           "--with-distro=GNU guix"
+                           "--disable-doc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'fix-service
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Don't copy config file
+             (substitute* "Makefile"
+               ((".*/service/realmd-.*") "")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("glib-bin" ,glib "bin")
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (inputs
+     `(("glib" ,glib)
+       ("mit-krb5" ,mit-krb5)
+       ("openldap" ,openldap)
+       ("polkit" ,polkit)))
+    (synopsis "DBus service for network authentication")
+    (description "This package provides an on demand system DBus service.
+It allows callers to configure network authentication and domain membership
+in a standard way.  Realmd discovers information about the domain or realm
+automatically and does not require complicated configuration in order to join
+a domain or realm.  Dbus system service that manages discovery and enrollment in
+realms/domains like Active Directory or IPA.")
+    (home-page "https://www.freedesktop.org/software/realmd/")
+    (license license:lgpl2.1+)))
+
 (define-public rename
   (package
     (name "rename")
-- 
2.33.1