diff mbox series

[bug#68819,18/49] gnu: Add rust-async-pidfd-0.1.

Message ID 69f023fa78a7b61c43c52f43d9f96110d5df3944.1706630138.git.herman@rimm.ee
State New
Headers show
Series None | expand

Commit Message

Herman Rimm Jan. 30, 2024, 4 p.m. UTC
* gnu/packages/crates-io.scm (rust-async-pidfd-0.1): Add variable.
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1eda29abf5..d9fa7b4b0c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3910,6 +3910,31 @@  (define-public rust-async-oneshot-0.5
 async-aware oneshot channel.")
     (license license:mpl2.0)))
 
+(define-public rust-async-pidfd-0.1
+  (package
+    (name "rust-async-pidfd")
+    (version "0.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "async-pidfd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "168pylpf7n898szw32sva7kf9h3x1mnip54mfr8f7f4v55c705qj"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-async-io" ,rust-async-io-1)
+                       ("rust-libc" ,rust-libc-0.2))
+       #:cargo-development-inputs
+       (("rust-futures-lite" ,rust-futures-lite-1))))
+    (home-page "https://github.com/joshtriplett/async-pidfd")
+    (synopsis "Process file descriptors (pidfd) for Linux")
+    (description
+      "@code{async-pidfd} provides Rust support for pidfd, and supports
+managing processes both synchronously (via the PidFd type) and
+asynchronously (via the AsyncPidFd type).")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-async-process-1
   (package
     (name "rust-async-process")