diff mbox series

[bug#38272] gnu: Add emacs-openwith.

Message ID 69ad356e-7f07-41df-b381-dfc90e71454d@www.fastmail.com
State Accepted
Headers show
Series [bug#38272] gnu: Add emacs-openwith. | expand

Commit Message

David Wilson Nov. 20, 2019, 1:53 p.m. UTC
Hi Marius, thanks for the reply!

On Tue, Nov 19, 2019, at 12:21 PM, Marius Bakke wrote:
> 
> The actual home page is here according to the README:
> 
> https://bitbucket.org/jpkotta/openwith
> 

Thanks!  Fixed.

> 
> This synopsis is a bit short.  :-)
> 

I swear I put something in for that, sorry I missed it!

> 
> Maybe "This package lets you associate file name patterns with
> external applications that are automatically invoked when you use
> commands like @code{find-file}, etc".
> 

I've taken your suggestion and improved on it like so:

"This package enables you to associate file name patterns with external
applications that are automatically invoked when you use commands like
@code{find-file}.  For example, you can have it open @code{png} files with
@code{feh} and @code{mp4} files with @code{mpv}.  This is especially useful
when browsing files with Dired."

Updated patch is attached, thanks again!

David

Comments

Marius Bakke Nov. 21, 2019, 6:36 p.m. UTC | #1
"David Wilson" <david@daviwil.com> writes:

>> 
>> Maybe "This package lets you associate file name patterns with
>> external applications that are automatically invoked when you use
>> commands like @code{find-file}, etc".
>> 
>
> I've taken your suggestion and improved on it like so:
>
> "This package enables you to associate file name patterns with external
> applications that are automatically invoked when you use commands like
> @code{find-file}.  For example, you can have it open @code{png} files with
> @code{feh} and @code{mp4} files with @code{mpv}.  This is especially useful
> when browsing files with Dired."

Thank you!  That description is much better.  :-)

> Updated patch is attached, thanks again!

I found that 'git-fetch' failed, so I changed the patch to use
'hg-fetch'.  It still produced the same hash.

But, I read in another message that BitBucket is shutting down Mercurial
support in 2020, so I'm not sure what to do about it.  Thoughts?

In any case the patch is applied!
Simon Tournier Nov. 22, 2019, 2:05 p.m. UTC | #2
Hi Marius,

On Thu, 21 Nov 2019 at 19:37, Marius Bakke <mbakke@fastmail.com> wrote:

> But, I read in another message that BitBucket is shutting down Mercurial
> support in 2020, so I'm not sure what to do about it.  Thoughts?

The timeline of the shutdown is here [1] so we have still some time. :-)

The best seems to first list all the packages offended via some scheme
code -- I have no idea how many packages will be impacted.
Then contact each upstream to know what is their plan, i.e., where the
new location of the source will be: git conversion and still on
BitBucket; still hg and move to elsewhere; etc.

I do not know if it is better to open only one bug report to track the
progress (maybe my preference), or to open one bug report per package.

What do you think?


All the best,
simon

[1] https://bitbucket.org/blog/sunsetting-mercurial-support-in-bitbucket
Marius Bakke Nov. 24, 2019, 10:28 p.m. UTC | #3
zimoun <zimon.toutoune@gmail.com> writes:

> Hi Marius,
>
> On Thu, 21 Nov 2019 at 19:37, Marius Bakke <mbakke@fastmail.com> wrote:
>
>> But, I read in another message that BitBucket is shutting down Mercurial
>> support in 2020, so I'm not sure what to do about it.  Thoughts?
>
> The timeline of the shutdown is here [1] so we have still some time. :-)
>
> [1] https://bitbucket.org/blog/sunsetting-mercurial-support-in-bitbucket

Thanks for the link.  I hope the affected archives will be available
through the Software Heritage API for the time travellers among us.

> The best seems to first list all the packages offended via some scheme
> code -- I have no idea how many packages will be impacted.
> Then contact each upstream to know what is their plan, i.e., where the
> new location of the source will be: git conversion and still on
> BitBucket; still hg and move to elsewhere; etc.

For this package in particular, I think it's okay to go with the
original emacsmirror source David used, as the code had not changed
since 2012.  :-)

More active packages probably already have a migration plan, so I
suppose we'll have to deal with it on a case by case basis.

> I do not know if it is better to open only one bug report to track the
> progress (maybe my preference), or to open one bug report per package.
>
> What do you think?

I think one bug to track it is sufficient, but no strong opinion.
diff mbox series

Patch

From c53654238337dda9f6cad64f69dea87cedd0450f Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Tue, 19 Nov 2019 06:24:31 -0800
Subject: [PATCH] gnu: Add emacs-openwith.

* gnu/packages/emacs-xyz.scm (emacs-openwith) New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6dcbd00307..a2e9164001 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10272,6 +10272,30 @@  list of commands is displayed in a handy popup.")
 characters from end of lines.")
     (license license:gpl3+)))
 
+(define-public emacs-openwith
+  (let ((commit "1dc89670822966fab6e656f6519fdd7f01e8301a")
+        (revision "0"))
+    (package
+      (name "emacs-openwith")
+      (home-page "https://bitbucket.org/jpkotta/openwith")
+      (version (git-version "0.0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference (url home-page) (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1wl6gnxsyhaad4cl9bxjc0qbc5jzvlwbwjbajs0n1s6qr07d6r01"))))
+      (build-system emacs-build-system)
+      (synopsis "Open external applications for files with Emacs")
+      (description
+       "This package enables you to associate file name patterns with external
+applications that are automatically invoked when you use commands like
+@code{find-file}.  For example, you can have it open @code{png} files with
+@code{feh} and @code{mp4} files with @code{mpv}.  This is especially useful
+when browsing files with Dired.")
+      (license license:gpl2+))))
+
 (define-public emacs-org-edit-latex
   (package
     (name "emacs-org-edit-latex")
-- 
2.24.0