[bug#77442,2/2] gnu: Remove r-h5.

Message ID 69744c9f90b8c87efd63c107654ac7818682fee9.1743547708.git.andreas@enge.fr
State New
Headers
Series Remove a deprecated R package and a depending package |

Commit Message

Andreas Enge April 1, 2025, 10:51 p.m. UTC
  The package has been deprecated by its author in 2017 in favor of r-hdf5r.
It does not build with current hdf5@1.14.

* gnu/packages/cran.scm (r-h5): Delete variable.

Change-Id: Iaceb59b31af870a1aea1630d74bb5c03932808b0
---
 gnu/packages/cran.scm | 29 -----------------------------
 1 file changed, 29 deletions(-)
  

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e96d70849..8d80bc2091 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14921,35 +14921,6 @@  (define-public r-heatmaply
     ;; Either version of the license.
     (license (list license:gpl2 license:gpl3))))
 
-(define-public r-h5
-  (package
-    (name "r-h5")
-    (version "0.9.9")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (cran-uri "h5" version))
-       (sha256
-        (base32
-         "14p7i1sj24ky87kd7qr3n9fc9l64s0bp0rwbyl6i2x69xn75gpsx"))))
-    (build-system r-build-system)
-    (inputs
-     (list zlib hdf5-1.10))
-    (native-inputs
-     (list r-knitr r-testthat which))
-    (propagated-inputs
-     (list r-rcpp))
-    (home-page "https://github.com/mannau/h5")
-    (synopsis "Interface to the HDF5 Library")
-    (description
-     "This package provides an S4 interface to the HDF5 library supporting
-fast storage and retrieval of R-objects like vectors, matrices and arrays to
-binary files in a language independent format.  The HDF5 format can therefore
-be used as an alternative to R's save/load mechanism.  Since h5 is able to
-access only subsets of stored data it can also handle data sets which do not
-fit into memory.")
-    (license license:bsd-2)))
-
 (define-public r-cgdsr
   (package
     (name "r-cgdsr")