diff mbox series

[bug#43349] gnu: Fix a crash in NTP and Chrony.

Message ID 6971c2fbbd8459ff52dbb7737c2cf444a9175a73.1599882442.git.leo@famulari.name
State Accepted
Headers show
Series [bug#43349] gnu: Fix a crash in NTP and Chrony. | expand

Commit Message

Leo Famulari Sept. 12, 2020, 3:47 a.m. UTC
Fixes <https://bugs.gnu.org/43321>.

* gnu/packages/ntp.scm (ntp, chrony)[inputs]: Replace libcap with libcap/next.
---
 gnu/packages/ntp.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Sept. 13, 2020, 7:48 p.m. UTC | #1
I tested on bare metal and virtualized x86-64 with NTP.

The bug reporter [0] tested that the fix worked for Chrony.

Pushed as 898fbb60b2354e82e5b7f259b44dbfed112a83aa

[0] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=43321#5
diff mbox series

Patch

diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 6b725c2b0f..5fa7d55845 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -80,7 +80,7 @@ 
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("libcap" ,libcap)
+     `(("libcap" ,libcap/next)
        ("libseccomp" ,libseccomp)
        ("nettle" ,nettle)))
     (home-page "https://chrony.tuxfamily.org/")
@@ -143,7 +143,7 @@  time-stamping or reference clock, sub-microsecond accuracy is possible.")
       ;; to run as non-root (when invoked with '-u'.)
       ,@(if (string-suffix? "-linux"
                             (or (%current-target-system) (%current-system)))
-            `(("libcap" ,libcap))
+            `(("libcap" ,libcap/next))
             '())))
    (arguments
     `(#:phases