[bug#75881] gnu: Add python-pypubsub.

Message ID 697017eece49f82395a0520f527ce1908506fcd1.1737932847.git.mail@pisemsky.site
State New
Headers
Series [bug#75881] gnu: Add python-pypubsub. |

Commit Message

Evgeny Pisemsky Jan. 26, 2025, 11:07 p.m. UTC
  * gnu/packages/python-xyz.scm (python-pypubsub): New variable.

Change-Id: I543d8a6297c374e55809a755a902250ca4d270d9
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++--
 1 file changed, 34 insertions(+), 2 deletions(-)


base-commit: 2ef62487045e8c10870f9105b841d66838476c37
  

Comments

Sharlatan Hellseher Feb. 4, 2025, 12:58 p.m. UTC | #1
Hi

Thank you for the patch.

I've applied some adjustments to indentation:
--8<---------------cut here---------------start------------->8---
modified   gnu/packages/python-xyz.scm
@@ -38375,21 +38375,25 @@ (define-public python-pypubsub
     (build-system pyproject-build-system)
     (arguments
      (list
-      #:phases #~(modify-phases %standard-phases
-                   (replace 'check
-                     (lambda* (#:key tests? #:allow-other-keys)
-                       (when tests?
-                         (with-directory-excursion "tests/suite"
-                           (invoke "py.test"))))))))
-    (native-inputs (list python-pytest python-setuptools python-wheel))
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion "tests/suite"
+                  (invoke "py.test"))))))))
+    (native-inputs
+     (list python-pytest
+           python-setuptools
+           python-wheel))
     (home-page "https://github.com/schollii/pypubsub")
     (synopsis "Python publish-subcribe library")
     (description
-     "This library provides a publish-subscribe API to facilitate
-event-based or message-based architecture in a single-process
-application.  It is centered on the notion of a topic - senders
-publish messages of a given topic, and listeners subscribe to messages
-of a given topic, all inside the same process.")
+     "This library provides a publish-subscribe API to facilitate event-based
+or message-based architecture in a single-process application.  It is centered
+on the notion of a topic - senders publish messages of a given topic, and
+listeners subscribe to messages of a given topic, all inside the same
+process.")
     (license license:bsd-2)))
 
 (define-public python-queuelib
--8<---------------cut here---------------end--------------->8---

Pushed to master as

ac9fc0db767 * master gnu: Add python-pypubsub.

Closing as competed.

--
Oleg
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7fcf9c3ba8..ca1c39b697 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -116,7 +116,7 @@ 
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
-;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2022, 2024, 2025 Evgeny Pisemsky <mail@pisemsky.site>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
@@ -157,7 +157,6 @@ 
 ;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
 ;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
-;;; Copyright © 2024, 2025 Evgeny Pisemsky <mail@pisemsky.site>
 ;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
 ;;; Copyright © 2025 Jordan Moore <lockbox@struct.foo>
 ;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
@@ -38277,6 +38276,39 @@  (define-public python-pyee
 and threaded programming in python, such as async/await.")
     (license license:expat)))
 
+(define-public python-pypubsub
+  (package
+    (name "python-pypubsub")
+    (version "4.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/schollii/pypubsub")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02j74w28wzmdvxkk8i561ywjgizjifq3hgcl080yj0rvkd3wivlb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         (with-directory-excursion "tests/suite"
+                           (invoke "py.test"))))))))
+    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (home-page "https://github.com/schollii/pypubsub")
+    (synopsis "Python publish-subcribe library")
+    (description
+     "This library provides a publish-subscribe API to facilitate
+event-based or message-based architecture in a single-process
+application.  It is centered on the notion of a topic - senders
+publish messages of a given topic, and listeners subscribe to messages
+of a given topic, all inside the same process.")
+    (license license:bsd-2)))
+
 (define-public python-queuelib
   (package
     (name "python-queuelib")