diff mbox series

[bug#67903] gnu: libcgroup: Update to 3.1.0.

Message ID 696e1a46af20d62029c36f5e2ad2c2ff22c0485f.1702995464.git.hako@ultrarare.space
State New
Headers show
Series [bug#67903] gnu: libcgroup: Update to 3.1.0. | expand

Commit Message

Hilton Chain Dec. 19, 2023, 2:21 p.m. UTC
* gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
[arguments]<#:configure-flags>: Disable systemd.

Change-Id: I67fe380ebdf91ca254b3365b7f237a3d9ad4f0a5
---
 gnu/packages/linux.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)


base-commit: fa92a7c2fe0c5b9e9923ad5f53bafd41aa6dbe66

Comments

郑俊杰 Dec. 24, 2023, 5:27 a.m. UTC | #1
> 在 2023年12月19日,22:51,Hilton Chain via Guix-patches via <guix-patches@gnu.org> 写道:
> 
> * gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
> [arguments]<#:configure-flags>: Disable systemd.
> 
> Change-Id: I67fe380ebdf91ca254b3365b7f237a3d9ad4f0a5
> ---
> gnu/packages/linux.scm | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 3ca756dead..c4c366e21f 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -8798,7 +8798,7 @@ (define-public fbgrab
> (define-public libcgroup
>   (package
>     (name "libcgroup")
> -    (version "2.0.2")
> +    (version "3.1.0")
>     (home-page "https://github.com/libcgroup/libcgroup")
>     (source
>      (origin
> @@ -8806,14 +8806,15 @@ (define-public libcgroup
>        (uri (string-append home-page "/releases/download/v"
>                            version "/" name "-" version ".tar.gz"))

Can we switch to git-fetch? 
And don’t use home-page in source.

>        (sha256
> -        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
> +        (base32 "0n0jkvmagw14vgwx3j5b6vv5h25lasrg2a7xihq9h11ww2qw8vlp"))))
>     (build-system gnu-build-system)
>     (arguments
>      ;; Tests are virtualized with lxc, it is not very feasible
>      ;; to make them executable under guix build. Also, note that
>      ;; origin is using source tarball release which is prepared
>      ;; after testing.
> -     `(#:tests? #f))
> +     `(#:tests? #f
> +       #:configure-flags '("--disable-systemd")))

Maybe use gexp. 

>     (native-inputs
>      (list bison flex))
>     (inputs
> 
> base-commit: fa92a7c2fe0c5b9e9923ad5f53bafd41aa6dbe66
> --
> 2.41.0

Other LGTM 

> 
> 
> 
>
Hilton Chain Jan. 5, 2024, 5:24 a.m. UTC | #2
Hi,

On Sun, 24 Dec 2023 13:27:13 +0800,
郑俊杰 wrote:
>
>
>
> > 在 2023年12月19日,22:51,Hilton Chain via Guix-patches via <guix-patches@gnu.org> 写道:
> >
> > * gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
> > [arguments]<#:configure-flags>: Disable systemd.
> >
> > Change-Id: I67fe380ebdf91ca254b3365b7f237a3d9ad4f0a5
> > ---
> > gnu/packages/linux.scm | 7 ++++---
> > 1 file changed, 4 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> > index 3ca756dead..c4c366e21f 100644
> > --- a/gnu/packages/linux.scm
> > +++ b/gnu/packages/linux.scm
> > @@ -8798,7 +8798,7 @@ (define-public fbgrab
> > (define-public libcgroup
> >   (package
> >     (name "libcgroup")
> > -    (version "2.0.2")
> > +    (version "3.1.0")
> >     (home-page "https://github.com/libcgroup/libcgroup")
> >     (source
> >      (origin
> > @@ -8806,14 +8806,15 @@ (define-public libcgroup
> >        (uri (string-append home-page "/releases/download/v"
> >                            version "/" name "-" version ".tar.gz"))
>
> Can we switch to git-fetch?

Is there any good reason?

> And don’t use home-page in source.

No problem.

> >        (sha256
> > -        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
> > +        (base32 "0n0jkvmagw14vgwx3j5b6vv5h25lasrg2a7xihq9h11ww2qw8vlp"))))
> >     (build-system gnu-build-system)
> >     (arguments
> >      ;; Tests are virtualized with lxc, it is not very feasible
> >      ;; to make them executable under guix build. Also, note that
> >      ;; origin is using source tarball release which is prepared
> >      ;; after testing.
> > -     `(#:tests? #f))
> > +     `(#:tests? #f
> > +       #:configure-flags '("--disable-systemd")))
>
> Maybe use gexp.

Will add in a later commit.

> >     (native-inputs
> >      (list bison flex))
> >     (inputs
> >
> > base-commit: fa92a7c2fe0c5b9e9923ad5f53bafd41aa6dbe66
> > --
> > 2.41.0
>
> Other LGTM

Thanks for the review!
Zheng Junjie Jan. 5, 2024, 5:45 a.m. UTC | #3
Hilton Chain <hako@ultrarare.space> writes:

> Hi,
>
> On Sun, 24 Dec 2023 13:27:13 +0800,
> 郑俊杰 wrote:
>>
>>
>>
>> > 在 2023年12月19日,22:51,Hilton Chain via Guix-patches via <guix-patches@gnu.org> 写道:
>> >
>> > * gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
>> > [arguments]<#:configure-flags>: Disable systemd.
>> >
>> > Change-Id: I67fe380ebdf91ca254b3365b7f237a3d9ad4f0a5
>> > ---
>> > gnu/packages/linux.scm | 7 ++++---
>> > 1 file changed, 4 insertions(+), 3 deletions(-)
>> >
>> > diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
>> > index 3ca756dead..c4c366e21f 100644
>> > --- a/gnu/packages/linux.scm
>> > +++ b/gnu/packages/linux.scm
>> > @@ -8798,7 +8798,7 @@ (define-public fbgrab
>> > (define-public libcgroup
>> >   (package
>> >     (name "libcgroup")
>> > -    (version "2.0.2")
>> > +    (version "3.1.0")
>> >     (home-page "https://github.com/libcgroup/libcgroup")
>> >     (source
>> >      (origin
>> > @@ -8806,14 +8806,15 @@ (define-public libcgroup
>> >        (uri (string-append home-page "/releases/download/v"
>> >                            version "/" name "-" version ".tar.gz"))
>>
>> Can we switch to git-fetch?
>
> Is there any good reason?

if use git-fetch, allow `guix build libcgroup
--with-{branch,commit,git-url} ...` work.



>
>> And don’t use home-page in source.
>
> No problem.
>
>> >        (sha256
>> > -        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
>> > +        (base32 "0n0jkvmagw14vgwx3j5b6vv5h25lasrg2a7xihq9h11ww2qw8vlp"))))
>> >     (build-system gnu-build-system)
>> >     (arguments
>> >      ;; Tests are virtualized with lxc, it is not very feasible
>> >      ;; to make them executable under guix build. Also, note that
>> >      ;; origin is using source tarball release which is prepared
>> >      ;; after testing.
>> > -     `(#:tests? #f))
>> > +     `(#:tests? #f
>> > +       #:configure-flags '("--disable-systemd")))
>>
>> Maybe use gexp.
>
> Will add in a later commit.
>
>> >     (native-inputs
>> >      (list bison flex))
>> >     (inputs
>> >
>> > base-commit: fa92a7c2fe0c5b9e9923ad5f53bafd41aa6dbe66
>> > --
>> > 2.41.0
>>
>> Other LGTM
>
> Thanks for the review!
Hilton Chain Jan. 13, 2024, 8:04 a.m. UTC | #4
Hi,

On Fri, 05 Jan 2024 13:45:36 +0800,
Zheng Junjie wrote:
>
> Hilton Chain <hako@ultrarare.space> writes:
> >
> > On Sun, 24 Dec 2023 13:27:13 +0800,
> > 郑俊杰 wrote:
> >>
> >> > 在 2023年12月19日,22:51,Hilton Chain 写道:
> >> >
> >> > * gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
> >> > [arguments]<#:configure-flags>: Disable systemd.
> >> >
> >> > Change-Id: I67fe380ebdf91ca254b3365b7f237a3d9ad4f0a5
> >> > ---
> >> > gnu/packages/linux.scm | 7 ++++---
> >> > 1 file changed, 4 insertions(+), 3 deletions(-)
> >> >
> >> > diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> >> > index 3ca756dead..c4c366e21f 100644
> >> > --- a/gnu/packages/linux.scm
> >> > +++ b/gnu/packages/linux.scm
> >> > @@ -8798,7 +8798,7 @@ (define-public fbgrab
> >> > (define-public libcgroup
> >> >   (package
> >> >     (name "libcgroup")
> >> > -    (version "2.0.2")
> >> > +    (version "3.1.0")
> >> >     (home-page "https://github.com/libcgroup/libcgroup")
> >> >     (source
> >> >      (origin
> >> > @@ -8806,14 +8806,15 @@ (define-public libcgroup
> >> >        (uri (string-append home-page "/releases/download/v"
> >> >                            version "/" name "-" version ".tar.gz"))
> >>
> >> Can we switch to git-fetch?
> >
> > Is there any good reason?
>
> if use git-fetch, allow `guix build libcgroup
> --with-{branch,commit,git-url} ...` work.


Yes, that makes sense, but we still have ‘--with-version’, right?  It seems that
libcgroup's release tarball is created by ‘make dist’ and for this specific case
these options are of less use, I'd prefer not switching to git-fetch.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ca756dead..c4c366e21f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8798,7 +8798,7 @@  (define-public fbgrab
 (define-public libcgroup
   (package
     (name "libcgroup")
-    (version "2.0.2")
+    (version "3.1.0")
     (home-page "https://github.com/libcgroup/libcgroup")
     (source
      (origin
@@ -8806,14 +8806,15 @@  (define-public libcgroup
        (uri (string-append home-page "/releases/download/v"
                            version "/" name "-" version ".tar.gz"))
        (sha256
-        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
+        (base32 "0n0jkvmagw14vgwx3j5b6vv5h25lasrg2a7xihq9h11ww2qw8vlp"))))
     (build-system gnu-build-system)
     (arguments
      ;; Tests are virtualized with lxc, it is not very feasible
      ;; to make them executable under guix build. Also, note that
      ;; origin is using source tarball release which is prepared
      ;; after testing.
-     `(#:tests? #f))
+     `(#:tests? #f
+       #:configure-flags '("--disable-systemd")))
     (native-inputs
      (list bison flex))
     (inputs