diff mbox series

[bug#69461,mesa-updates,01/13] gnu: spirv-headers: Update to vulkan-sdk-1.3.275.0.

Message ID 6925020499c96ba08bb9cf59615c6ec96a4f24cd.1709140055.git.i@dan.games
State New
Headers show
Series Update vulkan-sdk and add dirctx-shader-compiler. | expand

Commit Message

dan Feb. 28, 2024, 5:31 p.m. UTC
* gnu/packages/vulkan.scm (spirv-headers): Update to vulkan-sdk-1.3.275.0.

Change-Id: Ibe72c71d0d269f1e3bddba1d880a4d5fce8ed4a9
---
 gnu/packages/vulkan.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 285d6be7f5..2fb1884795 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2020, 2023 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
-;;; Copyright © 2022 dan <i@dan.games>
+;;; Copyright © 2022, 2024 dan <i@dan.games>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -47,7 +47,7 @@  (define-module (gnu packages vulkan)
   #:use-module (gnu packages xorg))
 
 ;; Note: Remember to change vulkan-loader version when bumping this.
-(define %vulkan-sdk-version "sdk-1.3.231.1")
+(define %vulkan-sdk-version "vulkan-sdk-1.3.275.0")
 
 (define-public spirv-headers
   (package
@@ -60,12 +60,11 @@  (define-public spirv-headers
              (url "https://github.com/KhronosGroup/SPIRV-Headers")
              (commit version)))
        (sha256
-        (base32
-         "0z8b485hryya2g0jxv7amwg3fjj7pchbgnsa5ldf5fwgh5js0icm"))
+        (base32 "18gr715ap9w1rjvzd6l9pl9lwfqiikm2la5apv2lplj4a0k5v3zw"))
        (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))                    ;no tests
+     `(#:tests? #f)) ;no tests
     (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
     (synopsis "Machine-readable files from the SPIR-V Registry")
     (description
@@ -76,10 +75,11 @@  (define-public spirv-headers
 @item JSON files describing the grammar for the SPIR-V core instruction set,
 and for the GLSL.std.450 extended instruction set.
 @item The XML registry file.
-@end itemize\n")
-    (license (license:x11-style
-              (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
-                             version "/LICENSE")))))
+@end itemize
+")
+    (license (license:x11-style (string-append
+                                 "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
+                                 version "/LICENSE")))))
 
 (define-public spirv-tools
   (package