diff mbox series

[bug#66278,gnome-team] gnu: telepathy-glib: Disable parallel tests.

Message ID 68dcb501ef696d3d66cf60798e3de9dc8bcf4a9a.1696067614.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#66278,gnome-team] gnu: telepathy-glib: Disable parallel tests. | expand

Commit Message

Liliana Marie Prikler Sept. 30, 2023, 8:33 a.m. UTC
* gnu/packages/glib.scm (telepathy-glib)[arguments]: Add #:parallel-tests?.
---
 gnu/packages/glib.scm | 2 ++
 1 file changed, 2 insertions(+)


base-commit: b18b2d13488f2a92331ccad2dc8cbb54ee15582f

Comments

Maxim Cournoyer Oct. 2, 2023, 3:39 a.m. UTC | #1
Hi!

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/glib.scm (telepathy-glib)[arguments]: Add #:parallel-tests?.
> ---
>  gnu/packages/glib.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index 8af89d60e0..2ba7d8039e 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -1129,6 +1129,8 @@ (define telepathy-glib
>         ;;   EOFError: EOF read where object expected
>         ;;   make[2]: *** [Makefile:1906: _gen/register-dbus-glib-marshallers-body.h] Error 1
>         #:parallel-build? #f
> +       ;; When spawned in parallel, the dbus daemons may fail to shut down cleanly.
> +       #:parallel-tests? #f
>         #:phases
>         (modify-phases %standard-phases
>           (add-after 'unpack 'disable-failing-tests

Good catch!  It should probably be reported upstream, but otherwise LGTM.
Liliana Marie Prikler Nov. 19, 2023, 8:54 a.m. UTC | #2
Am Sonntag, dem 01.10.2023 um 23:39 -0400 schrieb Maxim Cournoyer:
> Hi!
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/glib.scm (telepathy-glib)[arguments]: Add
> > #:parallel-tests?.
> > ---
> >  gnu/packages/glib.scm | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> > index 8af89d60e0..2ba7d8039e 100644
> > --- a/gnu/packages/glib.scm
> > +++ b/gnu/packages/glib.scm
> > @@ -1129,6 +1129,8 @@ (define telepathy-glib
> >         ;;   EOFError: EOF read where object expected
> >         ;;   make[2]: *** [Makefile:1906: _gen/register-dbus-glib-
> > marshallers-body.h] Error 1
> >         #:parallel-build? #f
> > +       ;; When spawned in parallel, the dbus daemons may fail to
> > shut down cleanly.
> > +       #:parallel-tests? #f
> >         #:phases
> >         (modify-phases %standard-phases
> >           (add-after 'unpack 'disable-failing-tests
> 
> Good catch!  It should probably be reported upstream, but otherwise
> LGTM.
Searched out existing bug reports and included them; then pushed.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 8af89d60e0..2ba7d8039e 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1129,6 +1129,8 @@  (define telepathy-glib
        ;;   EOFError: EOF read where object expected
        ;;   make[2]: *** [Makefile:1906: _gen/register-dbus-glib-marshallers-body.h] Error 1
        #:parallel-build? #f
+       ;; When spawned in parallel, the dbus daemons may fail to shut down cleanly.
+       #:parallel-tests? #f
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-failing-tests