diff mbox series

[bug#64940] gnu: Add termdown

Message ID 68d606b92416b5501da866d5840112be5eae2169.1690667339.git.abhiseckpaira@disroot.org
State New
Headers show
Series [bug#64940] gnu: Add termdown | expand

Commit Message

Abhiseck Paira July 29, 2023, 9:45 p.m. UTC
* gnu/packages/time.scm (termdown): New variable.
---
 gnu/packages/time.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: ecdcafc007e3a06647e02e2077e0ff352b38c06f
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 5c8f65a1e6..6d0c4c5aa1 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -606,6 +606,31 @@  (define-public tz
 TUI program that displays time across a few time zones of your choosing.")
     (license gpl3+)))
 
+(define-public termdown
+  (package
+    (name "termdown")
+    (version "1.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "termdown" version))
+       (sha256
+        (base32
+         "07nxsqpwnpr9jkvif2ngjlcq05z0ldnmqxd15d1l593lzmxdyrci"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-click
+           python-pyfiglet
+           python-dateutil))
+    (home-page "https://github.com/trehn/termdown")
+    (synopsis "Countdown timer for your terminal")
+    (description
+     "Termdown provides a fancy text display while it counts down to zero from
+a starting point you provide.  The user can pause and resume the countdown
+from the text user interface.  It can also be used in stop watch mode which
+counts forward or for just showing the current time.")
+    (license gpl3)))
+
 (define-public countdown
   (package
     (name "countdown")