diff mbox series

[bug#50398] gnu: Add python-w3lib

Message ID 6825432c68c83f41d7ab81994b8bc0dcc0443255.camel@courrier.dev
State Accepted
Headers show
Series [bug#50398] gnu: Add python-w3lib | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS Sept. 5, 2021, 8:28 a.m. UTC
From 7dc3c722627fbbecfe411a8b4d44f7b5cc12ba18 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 5 Sep 2021 10:25:14 +0200
Subject: [PATCH] gnu: Add python-w3lib

* gnu/packages/python-web.scm (python-w3lib): New variable.
---
 gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès Sept. 14, 2021, 9:27 a.m. UTC | #1
Hi,

Pradana Adrinusa AUMARS <paumars@courrier.dev> skribis:

>>From 7dc3c722627fbbecfe411a8b4d44f7b5cc12ba18 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sun, 5 Sep 2021 10:25:14 +0200
> Subject: [PATCH] gnu: Add python-w3lib
>
> * gnu/packages/python-web.scm (python-w3lib): New variable.

Applied, thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..47f7092147 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6205,3 +6206,25 @@  your code non-blocking and speedy.")
      "This project provides a client library in Python that makes it easy to
 communicate with Microsoft Azure Storage services.")
     (license license:expat)))
+
+(define-public python-w3lib
+  (package
+    (name "python-w3lib")
+    (version "1.22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "w3lib" version))
+       (sha256
+        (base32
+         "1pv02lvvmgz2qb61vz1jkjc04fgm4hpfvaj5zm4i3mjp64hd1mha"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/scrapy/w3lib")
+    (synopsis "Python library of web-related functions")
+    (description
+     "This is a Python library of web-related functions, such as: remove comments,
+or tags from HTML snippets, extract base url from HTML snippets, translate entites
+on HTML strings, among other things.")
+    (license license:bsd-3)))