[bug#76480,40/51] gnu: Add python-esutil.

Message ID 680c1bd7d3dfe7ff79df80df5e0fc697ade197d0.1740173176.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/02 |

Commit Message

Sharlatan Hellseher Feb. 21, 2025, 9:49 p.m. UTC
  * gnu/packages/astronomy.scm (python-esutil): New variable.

Change-Id: I0a2a5351639e18d5d5c95df3eebabb9650d17e1d
---
 gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b0a572ca993..1cc549c214f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2433,6 +2433,36 @@  (define-public python-ephem
 of dates.")
     (license license:expat)))
 
+(define-public python-esutil
+  (package
+    (name "python-esutil")
+    (version "0.6.16")
+    (source
+     (origin
+       (method git-fetch) ; no tests in the PyPI tarball
+       (uri (git-reference
+             (url "https://github.com/esheldon/esutil")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05csk5asq3si7gdq8mpfh288z10rs45ylpcrrcjx0009q52l95xq"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest
+           python-numpy
+           python-setuptools
+           python-wheel))
+    (propagated-inputs
+     (list python-numpy
+           python-scipy))
+    (home-page "https://github.com/esheldon/esutil")
+    (synopsis "Numerical, scientific, and astrophysical computing utilities")
+    (description
+     "This package provides a wide variety of utilities, focused primarily on
+numerical python, statistics, and file input/output.  Includes specialized
+tools for astronomers.")
+    (license license:gpl2+)))
+
 (define-public python-extinction
   (package
     (name "python-extinction")