diff mbox series

[bug#66624,emacs-team,14/15] gnu: emacs-eweouz: Build autoloads before installing them.

Message ID 67f7db53ef14c6b841230b0749ffb48e6dbd67b5.1697694142.git.liliana.prikler@gmail.com
State New
Headers show
Series Start reworking emacs-build-system | expand

Commit Message

Liliana Marie Prikler Oct. 19, 2023, 5:31 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eweouz)[#:phases]: Move
‘emacs-make-autoloads’ after ‘enter-lisp-dir’.
---
 gnu/packages/emacs-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a26cd0df6..113d6ce2bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3705,6 +3705,8 @@  (define-public emacs-eweouz
               (emacs-substitute-sexps "eweouz.el"
                 ("eweouz-helper-dirs"
                  `(list ,(string-append #$output "/libexec/eweouz"))))))
+          (add-after 'enter-lisp-dir 'emacs-make-autoloads
+            (assoc-ref emacs:%standard-phases 'make-autoloads))
           (add-after 'emacs-patch-variables 'emacs-expand-load-path
             (assoc-ref emacs:%standard-phases 'expand-load-path))
           (add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
@@ -3712,9 +3714,7 @@  (define-public emacs-eweouz
           (add-after 'emacs-add-install-to-native-load-path 'emacs-install
             (assoc-ref emacs:%standard-phases 'install))
           (add-after 'emacs-install 'emacs-build
-            (assoc-ref emacs:%standard-phases 'build))
-          (add-after 'emacs-install 'emacs-make-autoloads
-            (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+            (assoc-ref emacs:%standard-phases 'build)))))
     (native-inputs
      (list autoconf
            automake