[bug#75420,python-team,06/11] gnu: python-pytest-aiohttp: Update to 1.0.5.

Message ID 67aaccae01e88adce1c675d72e74bc40ff74f2d0.1736256868.git.arjan@adriaan.se
State New
Headers
Series Fix python-matrix-nio and pantalaimon builds. |

Commit Message

Arjan Adriaanse Jan. 7, 2025, 2:09 p.m. UTC
  * gnu/packages/python-check.scm (python-pytest-aiohttp): Update to 1.0.5.

Change-Id: Iea59c16220f28fa7c4cdd25f1cf05719ecec8733
---
 gnu/packages/python-check.scm | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1e6debc937..50601c5312 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1741,19 +1741,23 @@  (define-public python-pytest-toolbox
 (define-public python-pytest-aiohttp
   (package
     (name "python-pytest-aiohttp")
-    (version "0.3.0")
+    (version "1.0.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-aiohttp" version))
        (sha256
-        (base32
-         "0kx4mbs9bflycd8x9af0idcjhdgnzri3nw1qb0vpfyb3751qaaf9"))))
+        (base32 "02kq1bqsy9dlm9qckfiy9myizwcqna5szqqm7d339saib6y640l8"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-pytest))
+     (list python-coverage
+           python-mypy
+           python-setuptools-scm
+           python-wheel))
     (propagated-inputs
-     (list python-aiohttp))
+     (list python-aiohttp
+           python-pytest
+           python-pytest-asyncio))
     (home-page "https://github.com/aio-libs/pytest-aiohttp/")
     (synopsis "Pytest plugin for aiohttp support")
     (description "This package provides a pytest plugin for aiohttp support.")