[bug#78246,3/3] gnu: Add bitwuzla.

Message ID 67a4e964dce6af0c08c7d2cf22b2de697d2aec77.1746379841.git.soeren@soeren-tempel.net
State New
Headers
Series gnu: Add bitwuzla. |

Commit Message

Sören Tempel May 4, 2025, 5:40 p.m. UTC
  From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/maths.scm (bitwuzla): New variable.
---
 gnu/packages/maths.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 572912ca82..09ce6bcb7c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8274,6 +8274,44 @@  (define-public symfpu
       (home-page "https://github.com/martin-cs/symfpu")
       (license license:gpl3))))
 
+(define-public bitwuzla
+  (package
+    (name "bitwuzla")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/bitwuzla/bitwuzla")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fpd1kgb5xdbcjiqbbc6j0b8g2ly9bp9m3la78fiayl4qlmsvh2b"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags '("-Dtesting=enabled" "-Ddefault_library=shared"
+                           "-Dkissat=true")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'make-git-optional
+                    (lambda _
+                      (substitute* "src/meson.build"
+                        (("run_command\\('git',")
+                         "run_command('sh', '-c', 'git',")))))))
+    (native-inputs (list pkg-config
+                         googletest
+                         python
+                         gmp
+                         cadical
+                         symfpu
+                         kissat))
+    (synopsis "SMT solver optimized for the theory of bit-vectors")
+    (description
+     "@acronym{SMT, Satisfiability Modulo Theories} solver for the
+theories of fixed-size bit-vectors, floating-point arithmetic, arrays,
+uninterpreted functions and their combinations.")
+    (home-page "https://bitwuzla.github.io/")
+    (license license:expat)))
+
 (define-public z3
   (package
     (name "z3")