diff mbox series

[bug#70924,01/10] gnu: Add python-memory-allocator.

Message ID 676c926b816fad99606d7803b3b43156fe4696a1.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/sagemath.scm (python-memory-allocator): New variable.

Change-Id: Ib914cc736fa16c2a7bb2919d94aaf102e3513a60
---
 gnu/packages/sagemath.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c
diff mbox series

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 8d5d04ee93..9ccb7eb055 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@ 
 (define-module (gnu packages sagemath)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -94,6 +96,35 @@  (define-public python-gmpy2
 libraries GMO, MPFR and MPC.")
     (license license:lgpl3+)))
 
+(define-public python-memory-allocator
+  (package
+    (name "python-memory-allocator")
+    (version "0.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "memory_allocator" version))
+       (sha256
+        (base32 "1r7g175ddbpn5kjgs6f09s7mfachzw94p02snki6f6830dmj22fn"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-cython))
+    (home-page "https://github.com/sagemath/memory_allocator")
+    (synopsis "Extension class to allocate memory easily with Cython")
+    (description "This package provides a single extension class
+ @code{MemoryAllocator} with @{cdef} methods
+
+@itemize
+@item @code{malloc}
+@item @code{calloc}
+@item @code{allocarray}
+@item @code{realloc}
+@item @code{reallocarray}
+@item @code{aligned_malloc}
+@item @code{aligned_malloc}
+@item @code{aligned_calloc}
+@item @code{aligned_allocarray}")
+    (license license:gpl3+)))
+
 (define-public cliquer
   (package
     (name "cliquer")