diff mbox series

[bug#74355,v4,6/7] gnu: Add go-github-com-zeebo-blake3.

Message ID 675c23bbec3f474f6132345485f4b0da09702e63.1731771236.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#74355,v4,1/7] gnu: Add go-github-com-caddyserver-zerossl. | expand

Commit Message

Artyom V. Poptsov Nov. 16, 2024, 3:34 p.m. UTC
* gnu/packages/golang-crypto.scm (go-github-com-zeebo-blake3): New variable.

Change-Id: I23bc863fb1731b520aeca8e9088a98c6fcfcf62d
---
 gnu/packages/golang-crypto.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 168eb73ac4..7fdc502de6 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1727,6 +1727,35 @@  (define-public go-github-com-youmark-pkcs8
 PKCS#5 (v2.0) algorithms.")
     (license license:expat)))
 
+(define-public go-github-com-zeebo-blake3
+  (package
+    (name "go-github-com-zeebo-blake3")
+    (version "0.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zeebo/blake3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "117p973ccgalaqg7byj0qcd1xapysplql9np1sr9jkca500khcgf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/zeebo/blake3"))
+    (native-inputs (list go-github-com-zeebo-assert))
+    (propagated-inputs
+     (list go-github-com-klauspost-cpuid-v2
+           go-github-com-zeebo-pcg))
+    (home-page "https://github.com/zeebo/blake3")
+    (synopsis "Pure Go implementation of BLAKE3")
+    (description
+     "@code{blake3} is an implementation of
+@url{https://en.wikipedia.org/wiki/BLAKE_(hash_function)#BLAKE3, BLAKE3} with AVX2
+and SSE4.1 acceleration.")
+    (license license:cc0)))
+
 (define-public go-github-com-zeebo-pcg
   (package
     (name "go-github-com-zeebo-pcg")