diff mbox series

[bug#39213] gnu: Add regrader.

Message ID 67417190ae2cacc9d103c89cc523b0c6f6fef17f.camel@zrythm.org
State Accepted
Headers show
Series [bug#39213] gnu: Add regrader. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Jan. 21, 2020, 5:21 a.m. UTC
First release of a newly ported delay plugin!

This depends on #38689 getting merged

Thanks,
Alex

Comments

Alexandros Theodotou Feb. 25, 2020, 3:43 p.m. UTC | #1
Hi,

Please close this. I added a patch series to 
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38689

Thanks,
Alex
Efraim Flashner Feb. 26, 2020, 6:56 a.m. UTC | #2
On Tue, Feb 25, 2020 at 03:43:28PM +0000, Alexandros Theodotou wrote:
> Hi,
> 
> Please close this. I added a patch series to 
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38689
> 
> Thanks,
> Alex

The process to close a bug report is to send an email to
XXXXX-done@debbugs.gnu.org (which I CC'd in this message). So now you
know for next time :)
diff mbox series

Patch

From eaa7ddb16555f488484842bd55ce6406e0f374ab Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 21 Jan 2020 05:19:03 +0000
Subject: [PATCH] gnu: Add regrader.

* gnu/packages/music.scm (regrader): New variable.
---
 gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5e6509e6ca..30dd7e616b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5163,3 +5163,46 @@  code by PolyValens, offered as a VST plugin, an LV2 plugin and a standalone
 JACK application.")
     ;; Expat or CC0
     (license (list license:expat license:cc0))))
+
+(define-public regrader
+  (package
+    (name "regrader")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/regrader.git")
+               (commit (string-append "v" version))
+               ;; bundles a specific commit of the DISTRHO plugin framework
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0gl4d5lf2afqknz22jz7hh7029sc9v1xrz6nbz9dlv42bwc0cvl0"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "CC=gcc"))
+       #:phases
+       (modify-phases %standard-phases
+         ;; no configure script
+         (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("jack" ,jack-1)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("lv2" ,lv2)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/linuxmao-org/regrader")
+    (synopsis "Delay effect plugin")
+    (description
+     "Regrader is a delay effect where the repeats degrade in resolution.
+This is an unofficial port of the Regrader plugin created by Igorski.  It
+is available as an LV2 plugin, a VST plugin and a standalone JACK
+application.")
+    (license license:expat)))
-- 
2.24.1