diff mbox series

[bug#38904] gnu: Add gnome-color-manager.

Message ID 66fa4e1fc22ad1843d8996e9d687d0a0f18c2262.camel@disroot.org
State Accepted
Headers show
Series [bug#38904] gnu: Add gnome-color-manager. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 7:12 p.m. UTC
Hello Guix!

Please find the attached patch to add gnome-color-manager.

Regards,
RG.

Comments

Danny Milosavljevic Jan. 5, 2020, 10:19 a.m. UTC | #1
Hi RG,

>+    `(#:tests? #f)) ;;gcm-self-test fails due to no active display server

Trailing comments should have only one semicolon.

But better yet, since Guix packages build in a container, just start a display
server yourself.

For examples, search for "Xvfb" in the Guix source code.
diff mbox series

Patch

From 30098cf561ab3fb902a08718c159ad2f6820df32 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 14:10:04 -0500
Subject: [PATCH] gnu: Add gnome-color-manager.

* gnu/packages/gnome.scm (gnome-color-manager): New variable.
---
 gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 757091790d..102f679b53 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,45 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-color-manager
+  (package
+   (name "gnome-color-manager")
+   (version "3.32.0")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1vpxa2zjz3lkq9ldjg0fl65db9s6b4kcs8nyaqfz3jygma7ifg3w"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:tests? #f)) ;;gcm-self-test fails due to no active display server
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("gtk+:bin" ,gtk+ "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("adwaita-icon-theme" ,adwaita-icon-theme)
+      ("appstream-glib" ,appstream-glib)
+      ("colord-gtk" ,colord-gtk)
+      ("desktop-file-utils" ,desktop-file-utils)
+      ("exiv2" ,exiv2)
+      ("gnome-desktop" ,gnome-desktop)
+      ("itstool" ,itstool)
+      ("libcanberra" ,libcanberra)
+      ("libexif" ,libexif)
+      ("libtiff" ,libtiff)
+      ("vte" ,vte)))
+   (synopsis "Color profile manager for the GNOME desktop")
+   (description "GNOME Color Manager is a session framework that makes
+it easy to manage, install and generate color profiles
+in the GNOME desktop.")
+   (home-page "https://gitlab.gnome.org/GNOME/gnome-color-manager")
+   (license license:gpl2)))
+
 (define-public gssdp
   (package
    (name "gssdp")
-- 
2.24.1