From 30098cf561ab3fb902a08718c159ad2f6820df32 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 14:10:04 -0500
Subject: [PATCH] gnu: Add gnome-color-manager.
* gnu/packages/gnome.scm (gnome-color-manager): New variable.
---
gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
@@ -246,6 +246,45 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-color-manager
+ (package
+ (name "gnome-color-manager")
+ (version "3.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1vpxa2zjz3lkq9ldjg0fl65db9s6b4kcs8nyaqfz3jygma7ifg3w"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f)) ;;gcm-self-test fails due to no active display server
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("appstream-glib" ,appstream-glib)
+ ("colord-gtk" ,colord-gtk)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("exiv2" ,exiv2)
+ ("gnome-desktop" ,gnome-desktop)
+ ("itstool" ,itstool)
+ ("libcanberra" ,libcanberra)
+ ("libexif" ,libexif)
+ ("libtiff" ,libtiff)
+ ("vte" ,vte)))
+ (synopsis "Color profile manager for the GNOME desktop")
+ (description "GNOME Color Manager is a session framework that makes
+it easy to manage, install and generate color profiles
+in the GNOME desktop.")
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-color-manager")
+ (license license:gpl2)))
+
(define-public gssdp
(package
(name "gssdp")
--
2.24.1