diff mbox series

[bug#71953,v2,1/3] gnu: Add go-github-com-whyrusleeping-cbor-gen.

Message ID 66b591ef5f6566ca1d7b252c9050aaa4501533f3.1720336290.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#71953,v2,1/3] gnu: Add go-github-com-whyrusleeping-cbor-gen. | expand

Commit Message

Artyom V. Poptsov July 7, 2024, 7:13 a.m. UTC
* gnu/packages/ipfs.scm (go-github-com-whyrusleeping-cbor-gen): New variable.

Change-Id: I7fc01ba570492a145bcea00f08e0ccb7cc0479af
---
 gnu/packages/ipfs.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d75a99c4e1..f5ccd6cb8f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -449,6 +449,34 @@  (define-public go-github-com-ipfs-go-log
       #:go go-1.21
       #:import-path "github.com/ipfs/go-log"))))
 
+(define-public go-github-com-whyrusleeping-cbor-gen
+  (package
+    (name "go-github-com-whyrusleeping-cbor-gen")
+    (version "v0.0.0-20230818171029-f91ae536ca25")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/whyrusleeping/cbor-gen")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08by7pqh4fcwf2va01iif75yqkfssi6d48334404mmv9jmhzim60"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/whyrusleeping/cbor-gen"))
+    (propagated-inputs
+     (list go-github-com-ipfs-go-cid
+           go-github-com-google-go-cmp-cmp
+           go-golang-org-x-xerrors))
+    (home-page "https://github.com/whyrusleeping/cbor-gen")
+    (synopsis "Codegen for CBOR codecs on the specified types")
+    (description
+     "Basic utilities to generate fast path @url{https://cbor.io/, CBOR} codecs for
+types.")
+    (license license:expat)))
+
 (define-public gx
   (package
     (name "gx")