diff mbox series

[bug#64419] gnu: Add emacs-eldoc-box.

Message ID 66b546e021e041521faf89cea1f615c12ecaa864.1688300843.git.hako@ultrarare.space
State New
Headers show
Series [bug#64419] gnu: Add emacs-eldoc-box. | expand

Commit Message

Hilton Chain July 2, 2023, 12:27 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eldoc-box): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: a919a16898e7219fdd26bdfe33a9959e7156d59d

Comments

Andrew Tropin July 10, 2023, 6:33 a.m. UTC | #1
On 2023-07-02 20:27, Hilton Chain wrote:

> * gnu/packages/emacs-xyz.scm (emacs-eldoc-box): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 6c86ee3793..9754a762b8 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -18623,6 +18623,28 @@ (define-public emacs-eldoc
>  variable instead, to remind you of that variable's meaning.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-eldoc-box
> +  (package
> +    (name "emacs-eldoc-box")
> +    (version "1.10.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/casouri/eldoc-box")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "076bbn2nnrx02zk2hs4b39q0w3s7afbgfdxnwk2y2s8lkq1l6l87"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/casouri/eldoc-box")
> +    (synopsis "Childframe doc for eglot and anything that uses eldoc")
> +    (description
> +     "This package displays ElDoc documentations in a childframe.  The
> +childfrme is selectable and scrollable with mouse, even thought the cursor is
> +hidden.")
> +    (license license:gpl3+)))
> +
>  ;; Tests for ert-runner have a circular dependency with ecukes, and therefore
>  ;; cannot be run
>  (define-public emacs-ert-runner
>
> base-commit: a919a16898e7219fdd26bdfe33a9959e7156d59d

Applied, pushed as 6663eb9aa7, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6c86ee3793..9754a762b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18623,6 +18623,28 @@  (define-public emacs-eldoc
 variable instead, to remind you of that variable's meaning.")
     (license license:gpl3+)))
 
+(define-public emacs-eldoc-box
+  (package
+    (name "emacs-eldoc-box")
+    (version "1.10.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/casouri/eldoc-box")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "076bbn2nnrx02zk2hs4b39q0w3s7afbgfdxnwk2y2s8lkq1l6l87"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/casouri/eldoc-box")
+    (synopsis "Childframe doc for eglot and anything that uses eldoc")
+    (description
+     "This package displays ElDoc documentations in a childframe.  The
+childfrme is selectable and scrollable with mouse, even thought the cursor is
+hidden.")
+    (license license:gpl3+)))
+
 ;; Tests for ert-runner have a circular dependency with ecukes, and therefore
 ;; cannot be run
 (define-public emacs-ert-runner