diff mbox series

[bug#38848] Fix path substitution in IBus

Message ID 66851577873749@myt5-b646bde4b8f3.qloud-c.yandex.net
State Accepted
Headers show
Series [bug#38848] Fix path substitution in IBus | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Kozlov Jan. 1, 2020, 10:15 a.m. UTC
The IBus package has been broken since forever because it substitutes paths to setxkbmap and xmodmap binaries with package directories.

---
gnu/packages/ibus.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--
2.23.0

Comments

Ricardo Wurmus Jan. 1, 2020, 10:56 p.m. UTC | #1
kanichos@yandex.ru writes:

> The IBus package has been broken since forever because it substitutes
> paths to setxkbmap and xmodmap binaries with package directories.

Oh, good catch!  Thanks!
(I’ve only ever been using libpinyin, so I never noticed…)

Pushed to the master branch with commit 92d7f5b45d.

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 5057927174..42a8d5db32 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -116,7 +116,7 @@ 
                               "/share/X11/locale")))
             (substitute* "ui/gtk3/xkblayout.vala"
               (("\"(setxkbmap|xmodmap)\"" _ prog)
-                (string-append "\"" (assoc-ref inputs prog) "\"")))
+                (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
             #t))
         (add-after 'wrap-program 'wrap-with-additional-paths
           (lambda* (#:key outputs #:allow-other-keys)