diff mbox series

[bug#64387,v2,4/6] gnu: arcan: Use new style arguments.

Message ID 667739ec06929fa054cae6c439d3567fd3e9a9da.1691691398.git.a.r.draidi@redscript.org
State New
Headers show
Series Update and rework arcan | expand

Commit Message

Ahmad Draidi Aug. 10, 2023, 6:16 p.m. UTC
* gnu/packages/arcan.scm (arcan)[arguments]: Use new style arguments.
---
 gnu/packages/arcan.scm | 50 ++++++++++++++++++++----------------------
 1 file changed, 24 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 159c6d2190..9c6092bb9e 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -75,32 +75,30 @@  (define-public arcan
                      (delete-file-recursively "external/sqlite")))))
       (build-system cmake-build-system)
       (arguments
-       `(#:configure-flags '("-DBUILD_PRESET=everything"
-                             "-DDISTR_TAG='Guix'")
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-paths
-             (lambda* (#:key outputs #:allow-other-keys)
-               (substitute* "src/platform/posix/paths.c"
-                 (("/usr/local")
-                  (assoc-ref outputs "out")))))
-           ;; Normally, it tries to fetch patched openal with git
-           ;; but copying files manually in the right place seems to work too.
-           (add-after 'unpack 'prepare-static-openal
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((arcan-openal (assoc-ref inputs "arcan-openal")))
-                 (copy-recursively arcan-openal "external/git/openal"))
-               #t))
-           (add-after 'prepare-static-openal 'generate-man
-             (lambda _
-               (with-directory-excursion "doc"
-                 (invoke "ruby" "docgen.rb" "mangen"))
-               #t))
-           (add-before 'configure 'chdir
-             (lambda _
-               (chdir "src")
-               #t)))
-         #:tests? #f))
+       (list #:configure-flags #~'("-DBUILD_PRESET=everything"
+                                   "-DDISTR_TAG='Guix'")
+             #:phases #~(modify-phases %standard-phases
+                          (add-after 'unpack 'patch-paths
+                            (lambda* (#:key outputs #:allow-other-keys)
+                              (substitute* "src/platform/posix/paths.c"
+                                (("/usr/local")
+                                 (assoc-ref outputs "out")))))
+                          ;; Normally, it tries to fetch patched openal with git
+                          ;; but copying files manually in the right place seems to work too.
+                          (add-after 'unpack 'prepare-static-openal
+                            (lambda* (#:key inputs #:allow-other-keys)
+                              (let ((arcan-openal (assoc-ref inputs
+                                                             "arcan-openal")))
+                                (copy-recursively arcan-openal
+                                                  "external/git/openal")) #t))
+                          (add-after 'prepare-static-openal 'generate-man
+                            (lambda _
+                              (with-directory-excursion "doc"
+                                (invoke "ruby" "docgen.rb" "mangen")) #t))
+                          (add-before 'configure 'chdir
+                            (lambda _
+                              (chdir "src") #t)))
+             #:tests? #f))
       (inputs
        `(("bash-minimal" ,bash-minimal)
          ("espeak" ,espeak)