diff mbox series

[bug#50859,core-updates-frozen,vv2] gnu: tzdata: Update to 2021c.

Message ID 6671ff8b38883a161f1a7d6e617cc53e74717c88.1633389249.git.leo@famulari.name
State Accepted
Headers show
Series [bug#50859,core-updates-frozen,vv2] gnu: tzdata: Update to 2021c. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Oct. 4, 2021, 11:14 p.m. UTC
* gnu/packages/base.scm (tzdata, tzdata-for-tests): Update to 2021c.
---
 gnu/packages/base.scm | 32 +++++++-------------------------
 1 file changed, 7 insertions(+), 25 deletions(-)

Comments

Maxim Cournoyer Oct. 12, 2021, 4:36 a.m. UTC | #1
Hello Leo,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/base.scm (tzdata, tzdata-for-tests): Update to 2021c.
> ---
>  gnu/packages/base.scm | 32 +++++++-------------------------
>  1 file changed, 7 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
> index 174af43917..1eea658791 100644
> --- a/gnu/packages/base.scm
> +++ b/gnu/packages/base.scm
> @@ -1230,7 +1230,7 @@ command.")
>      (name "tzdata")
>      ;; This package should be kept in sync with python-pytz in (gnu packages
>      ;; time).
> -    (version "2021a")
> +    (version "2021c")
>      (source (origin
>               (method url-fetch)
>               (uri (string-append
> @@ -1238,7 +1238,7 @@ command.")
>                     version ".tar.gz"))
>               (sha256
>                (base32
> -               "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
> +               "0himprzx3ahxkmg4rvp8n5lqry76qzc65j6sfq151hqirg4d3wdl"))))
>      (build-system gnu-build-system)
>      (arguments
>       (list #:tests? #f
> @@ -1306,7 +1306,7 @@ command.")
>                            version ".tar.gz"))
>                      (sha256
>                       (base32
> -                      "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb")))))
> +                      "01fsa661vzdij46z286pa8q07cppqz29sr2pf0qqldqpldbb6km3")))))
>      (home-page "https://www.iana.org/time-zones")
>      (synopsis "Database of current and historical time zones")
>      (description "The Time Zone Database (often called tz or zoneinfo)
> @@ -1321,28 +1321,10 @@ and daylight-saving rules.")
>  ;;; thousands of packages (for example, in a core-updates rebuild). This package
>  ;;; will typically be obsolete and should never be referred to by a built
>  ;;; package.

LGTM.

> -(define-public tzdata-for-tests
> -  (hidden-package
> -   (package
> -     (inherit tzdata)
> -     (version "2021a")
> -     (source (origin
> -               (method url-fetch)
> -               (uri (string-append
> -                     "https://data.iana.org/time-zones/releases/tzdata"
> -                     version ".tar.gz"))
> -               (sha256
> -                (base32
> -                 "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
> -     (inputs
> -      (list (origin
> -              (method url-fetch)
> -              (uri (string-append
> -                    "https://data.iana.org/time-zones/releases/tzcode"
> -                    version ".tar.gz"))
> -              (sha256
> -               (base32
> -                "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb"))))))))
> +;;;
> +;;; Please make this a hidden-package if it is different from the primary tzdata
> +;;; package.
> +(define-public tzdata-for-tests tzdata)

Why do we keep the above?  I'm sed it out of the code base instead.

If you want, I can push this change along 50358 when I get to it, which
will cause a world rebuild.

Thanks,

Maxim
Leo Famulari Oct. 16, 2021, 5:32 p.m. UTC | #2
On Tue, Oct 12, 2021 at 12:36:44AM -0400, Maxim Cournoyer wrote:
> Why do we keep the above?  I'm sed it out of the code base instead.
> 
> If you want, I can push this change along 50358 when I get to it, which
> will cause a world rebuild.

Sure, feel free. We can add tzdata-for-tests back when we want it again.
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 174af43917..1eea658791 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1230,7 +1230,7 @@  command.")
     (name "tzdata")
     ;; This package should be kept in sync with python-pytz in (gnu packages
     ;; time).
-    (version "2021a")
+    (version "2021c")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -1238,7 +1238,7 @@  command.")
                    version ".tar.gz"))
              (sha256
               (base32
-               "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
+               "0himprzx3ahxkmg4rvp8n5lqry76qzc65j6sfq151hqirg4d3wdl"))))
     (build-system gnu-build-system)
     (arguments
      (list #:tests? #f
@@ -1306,7 +1306,7 @@  command.")
                           version ".tar.gz"))
                     (sha256
                      (base32
-                      "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb")))))
+                      "01fsa661vzdij46z286pa8q07cppqz29sr2pf0qqldqpldbb6km3")))))
     (home-page "https://www.iana.org/time-zones")
     (synopsis "Database of current and historical time zones")
     (description "The Time Zone Database (often called tz or zoneinfo)
@@ -1321,28 +1321,10 @@  and daylight-saving rules.")
 ;;; thousands of packages (for example, in a core-updates rebuild). This package
 ;;; will typically be obsolete and should never be referred to by a built
 ;;; package.
-(define-public tzdata-for-tests
-  (hidden-package
-   (package
-     (inherit tzdata)
-     (version "2021a")
-     (source (origin
-               (method url-fetch)
-               (uri (string-append
-                     "https://data.iana.org/time-zones/releases/tzdata"
-                     version ".tar.gz"))
-               (sha256
-                (base32
-                 "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
-     (inputs
-      (list (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://data.iana.org/time-zones/releases/tzcode"
-                    version ".tar.gz"))
-              (sha256
-               (base32
-                "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb"))))))))
+;;;
+;;; Please make this a hidden-package if it is different from the primary tzdata
+;;; package.
+(define-public tzdata-for-tests tzdata)
 
 (define-public libiconv
   (package