diff mbox series

[bug#74416,v2,2/2] gnu: petsc: Remove store references on make and gcc.

Message ID 663600da2062af7334e0406a752cd571bf627ce0.1732025886.git.lars.bilke@ufz.de
State New
Headers show
Series [bug#74416,v2,1/2] gnu: petsc: Remove arch version from uname output. | expand

Commit Message

Lars Bilke Nov. 19, 2024, 2:18 p.m. UTC
Reduces closure size from 970 MB to around 700 MB for petsc-openmpi
package and also makes `guix pack` packages containing petsc
bit-reproducible (by removing make it removes implicit guile
dependency).

Change-Id: I465c325b152b09befdb746e5bc47fbeaf9a061dc
---
 gnu/packages/maths.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d76937265d..caa7b97b0c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3422,7 +3422,8 @@  (define-public petsc
                   ;; Prevent build directory from leaking into compiled code
                   (((getcwd)) out)
                   (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
-                    "Machine characteristics: Linux-x.x.x-archx-x"))
+                    "Machine characteristics: Linux-x.x.x-archx-x")
+                  (("([[:graph:]]+)/bin/make") "\"make"))
                 (substitute* (find-files "." "petscvariables")
                   ;; Do not expose build machine characteristics, set to defaults.
                   (("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")
@@ -3462,7 +3463,8 @@  (define-public petsc
                 (("([[:graph:]]+)/bin/make") "make")
                 (("([[:graph:]]+)/bin/diff") "diff")
                 (("([[:graph:]]+)/bin/sed") "sed")
-                (("([[:graph:]]+)/bin/gfortran") "gfortran")))))
+                (("([[:graph:]]+)/bin/gfortran") "gfortran")
+                (("([[:graph:]]+)/bin/gcov") "gcov")))))
 
           ;; Some of the tests get linked with '-L$prefix/lib -lpetsc' (even
           ;; though that's unnecessary because they also explicitly link