diff mbox series

[bug#59952] gnu: gauche: Update to 0.9.12

Message ID 66324e5d5efafe1bd601afc8c09d30f0d1a7d2ac.1670711267.git.contact@robbyzambito.me
State New
Headers show
Series [bug#59952] gnu: gauche: Update to 0.9.12 | expand

Commit Message

Robby Zambito Dec. 10, 2022, 10:27 p.m. UTC
* gnu/packages/scheme.scm (gauche): Update to 0.9.12.
[source]: Project migrated to GitHub.
libatomic-ops is no longer in the Gauche source tree.
[arguments]: Renamed network test file.
---
 gnu/packages/scheme.scm | 19 ++++++++-----------
 1 file changed, 8 insertions(+), 11 deletions(-)


base-commit: a7f41aac7ac5e07722f5038b0c5fa3ce2d7ce892

Comments

宋文武 Dec. 13, 2022, 6:11 a.m. UTC | #1
Robby Zambito <contact@robbyzambito.me> writes:

> * gnu/packages/scheme.scm (gauche): Update to 0.9.12.
> [source]: Project migrated to GitHub.
> libatomic-ops is no longer in the Gauche source tree.
> [arguments]: Renamed network test file.
> ---
>  gnu/packages/scheme.scm | 19 ++++++++-----------
>  1 file changed, 8 insertions(+), 11 deletions(-)

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index f0fbbb6331..e8427eaf8a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Robby Zambito <contact@robbyzambito.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -888,21 +889,17 @@  (define-public femtolisp
 (define-public gauche
   (package
     (name "gauche")
-    (version "0.9.10")
+    (version "0.9.12")
     (home-page "https://practical-scheme.net/gauche/index.html")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
-             "mirror://sourceforge/gauche/Gauche/Gauche-"
-             version ".tgz"))
+             "https://github.com/shirok/Gauche/releases/download/release"
+             (string-replace-substring version "." "_")
+             "/Gauche-" version ".tgz"))
        (sha256
-        (base32 "0ci57ak5cp3lkmfy3nh50hifh8nbg58hh6r18asq0rn5mqfxyf8g"))
-       (modules '((guix build utils)))
-       (snippet '(begin
-                   ;; Remove libatomic-ops.
-                   (delete-file-recursively "gc/libatomic_ops")
-                   #t))))
+        (base32 "05xnym1phg8i14bacip5d0d3v0gc1nn5mgayd5hnda873f969bml"))))
     (build-system gnu-build-system)
     (inputs
      (list libatomic-ops slib zlib))
@@ -933,8 +930,8 @@  (define-public gauche
          (add-before 'check 'patch-network-tests
            ;; Remove net checks.
            (lambda _
-             (delete-file "ext/net/test.scm")
-             (invoke "touch" "ext/net/test.scm")
+             (delete-file "test/net.scm")
+             (invoke "touch" "test/net.scm")
              #t))
          (add-after 'install 'install-docs
            (lambda _