diff mbox series

[bug#71600,2/2] gnu: quakespasm: Update package style.

Message ID 65f17f61a595030f40a0aaee3db0f7bc3f46b840.1718573761.git.jsubuntuxp@disroot.org
State New
Headers show
Series Update QuakeSpasm | expand

Commit Message

James Smith June 16, 2024, 9:43 p.m. UTC
* gnu/packages/games.scm (quakespasm)[arguments]: Use gexps.
<#:make-flags>: Set compiler to (cc-for-target) instead of hardcoding to gcc.
<#:phases>: Simplify fix-makefile-paths and remove trailing #t.

Change-Id: I250a842c78f2f49b451e5df76509fbe6fa1b4576
---
 gnu/packages/games.scm | 32 +++++++++++++++-----------------
 1 file changed, 15 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8d1450db01..5fe402d2eb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7676,23 +7676,21 @@  (define-public quakespasm
        (sha256
         (base32 "0hr58w1d2yw82vm9lkln05z6d4sjlcr6grxhf6sqdqwyfy9nv1mw"))))
     (arguments
-     `(#:tests? #f
-       #:make-flags '("CC=gcc"
-                      "MP3LIB=mpg123"
-                      "USE_CODEC_FLAC=1"
-                      "USE_CODEC_MIKMOD=1"
-                      "USE_SDL2=1"
-                      "-CQuake")
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure)
-                  (add-after 'unpack 'fix-makefile-paths
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out")))
-                        (mkdir-p (string-append out "/bin"))
-                        (substitute* "Quake/Makefile"
-                          (("/usr/local/games")
-                           (string-append out "/bin")))
-                        #t))))))
+     (list #:tests? #f
+           #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                "MP3LIB=mpg123"
+                                "USE_CODEC_FLAC=1"
+                                "USE_CODEC_MIKMOD=1"
+                                "USE_SDL2=1"
+                                "-CQuake")
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (add-after 'unpack 'fix-makefile-paths
+                          (lambda _
+                            (mkdir-p (string-append #$output "/bin"))
+                            (substitute* "Quake/Makefile"
+                              (("/usr/local/games")
+                               (string-append #$output "/bin"))))))))
     (build-system gnu-build-system)
     (inputs (list libmikmod
                   libvorbis