diff mbox series

[bug#69303] gnu: cage: Fix cross-compilation.

Message ID 65ce3a3297eaffee5702db21d53f3b9f781286f5.1708513939.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#69303] gnu: cage: Fix cross-compilation. | expand

Commit Message

Zheng Junjie Feb. 21, 2024, 11:12 a.m. UTC
* gnu/packages/wm.scm (cage)[native-inputs]: Add wayland.

Change-Id: I7f929570c8daa43872f7ecfb021bce6ec3e7b8f7
---
 gnu/packages/wm.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: bb87745253f5eca6697e91bf30a00b7f094496d8

Comments

Hilton Chain March 1, 2024, 6:24 a.m. UTC | #1
Hi,

On Wed, 21 Feb 2024 19:12:19 +0800,
Zheng Junjie wrote:
>
> * gnu/packages/wm.scm (cage)[native-inputs]: Add wayland.
>
> Change-Id: I7f929570c8daa43872f7ecfb021bce6ec3e7b8f7
> ---
>  gnu/packages/wm.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Applied as f1a0a28030d7f61c14b5c25100d0b3ace2c75238, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index acaa64b9e6..4a5af19e97 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,7 +41,7 @@ 
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
-;;; Copyright © 2021, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021, 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
@@ -208,7 +208,9 @@  (define-public cage
        (file-name (git-file-name name version))
        (sha256 (base32 "11sg9x08zl2nr7a723h462knz5lf58sgvkhv1mgc9z3hhkhvbsja"))))
     (build-system meson-build-system)
-    (native-inputs (list pkg-config scdoc))
+    (native-inputs (list pkg-config scdoc
+                         ;; for wayland-scanner
+                         wayland))
     (inputs (list wayland wlroots-0.16 libxkbcommon))
     (home-page "https://github.com/cage-kiosk/cage")
     (synopsis "Wayland kiosk")