[bug#76351] gnu: Add emacs-nushell-mode.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-nushell-mode): New variable.
Change-Id: I216d8a9f7e7f89e379174a5d93020ff44c69d51f
---
Ian,
Ian Eure <ian@retrospec.tv> writes:
> This needs to use `git-version'. While the package has no tagged
> releases, nushell-mode.el has 0.1.0 declared as its version[1], so
> using that is preferable to using a date.
Good catch, thanks! Here is my corrected patch.
Thanks,
Skylar
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: 6dde0ee30e5e030c2535514e9e39aa50518a5d20
prerequisite-patch-id: cc459efaf23197e58e97a6f0ad62058f71178746
prerequisite-patch-id: 492a9743436eae7679c7d9002f5b2d175eff9f1b
Comments
Hi Skylar,
Thanks for the fix, pushed as 2b94ea3880.
I have no idea how this caused a new bug to be opened & assigned
to me.
-- Ian
@@ -35629,6 +35629,29 @@ (define-public emacs-ntlm
implementation of Windows NT and LanManager compatible password encryption.")
(license license:gpl3+)))
+(define-public emacs-nushell-mode
+ (let ((commit "c179c3cf573b2cc9421dc08bf47e2d619c7791ee")
+ (revision "0"))
+ (package
+ (name "emacs-nushell-mode")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/nushell-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08kx31h22szvmccswwmhyj615c9fqln45darlfkj7q84dmc2fd3n"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mrkkrp/nushell-mode")
+ (synopsis "Major mode for Nushell scripts")
+ (description
+ "This package provides a very basic version of major mode for Nushell shell
+scripts.")
+ (license license:gpl3+))))
+
(define-public emacs-nadvice
(package
(name "emacs-nadvice")