[bug#74495,05/16] gnu: Add go-github-com-sahilm-fuzzy.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-sahilm-fuzzy): New variable.
Change-Id: Iebf4f8c3848e1e08b2860ac69a5a8d816ac260df
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -6635,6 +6635,32 @@ (define-public go-github-com-ryanuber-columnize
"This package implements column-formatted output for Golang.")
(license license:expat)))
+(define-public go-github-com-sahilm-fuzzy
+ (package
+ (name "go-github-com-sahilm-fuzzy")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sahilm/fuzzy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15j95gm7hcmg09x1b39vc4il8bryv4v0yljvvyq5vyc6iq66qrbz"))))
+ (build-system go-build-system)
+ (native-inputs (list go-github-com-kylelemons-godebug
+ go-github-com-kylelemons-godebug-pretty))
+ (arguments
+ (list
+ #:import-path "github.com/sahilm/fuzzy"))
+ (home-page "https://github.com/sahilm/fuzzy")
+ (synopsis "Fuzzy string matching for Golang")
+ (description
+ "@code{fuzzy} provides fuzzy string matching optimized for filenames and code
+symbols in the style of Sublime Text, VSCode, @code{IntelliJ} IDEA et al.")
+ (license license:expat)))
+
(define-public go-github-com-schollz-progressbar-v3
(package
(name "go-github-com-schollz-progressbar-v3")