diff mbox series

[bug#62228,v3,1/3] gnu: Prefix licenses in documentation.scm

Message ID 64b55303d5c8523dec00a48adcd88a7bbc17610b.1710106585.git.sarg@sarg.org.ru
State New
Headers show
Series [bug#62228,v3,1/3] gnu: Prefix licenses in documentation.scm | expand

Commit Message

Sergey Trofimov March 10, 2024, 9:36 p.m. UTC
* gnu/packages/documentation.scm: Prefix licenses.
---
 gnu/packages/documentation.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)


base-commit: c7836393be4d134861d652b2fcf09cf4e68275ca

Comments

Liliana Marie Prikler March 11, 2024, 7:31 p.m. UTC | #1
Am Sonntag, dem 10.03.2024 um 22:36 +0100 schrieb Sergey Trofimov:
> * gnu/packages/documentation.scm: Prefix licenses.
> ---
LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 5d455431d3..7aa43c1220 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -30,7 +30,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages documentation)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -104,7 +104,7 @@  (define-public latex2html
     (description "LaTeX2HTML is a utility that converts LaTeX documents to web
 pages in HTML.")
     (home-page "https://www.latex2html.org/")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public asciidoc
   (package
@@ -175,7 +175,7 @@  (define-public asciidoc
 AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
 the backend output markups (which can be almost any type of SGML/XML
 markup) can be customized and extended by the user.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-deprecated asciidoc-py3 asciidoc)
 
@@ -241,7 +241,7 @@  (define-public doxygen
 programming languages such as C, Objective-C, C#, PHP, Java, Python,
 IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,
 and to some extent D.")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public doc++
   (package
@@ -266,7 +266,7 @@  (define-public doc++
 generate both TeX output for high-quality hardcopies or HTML output for online
 browsing.  The documentation is extracted directly from the C/C++/IDL source
 or Java class files.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public pod2pdf
   (package
@@ -292,7 +292,7 @@  (define-public pod2pdf
 Documentation} format to PDF files.  It also supports some extensions to the POD
 format, and supports the file types JPG, GIF, TIFF, PNG, and PNM for embedded
 objects.")
-    (license artistic2.0)))
+    (license license:artistic2.0)))
 
 (define-public python-docrepr
   (package
@@ -344,7 +344,7 @@  (define-public python-docrepr
     (description "Docrepr renders Python docstrings to HTML with Sphinx.  It
 can generate rich and plain representations of docstrings, alongside
 additional metadata about the object to which the docstring belongs.")
-    (license bsd-3)))
+    (license license:bsd-3)))
 
 (define-public scrollkeeper
   (package
@@ -377,7 +377,7 @@  (define-public scrollkeeper
 provides a simple API to allow help browsers to find, sort, and search the
 document catalog.  It will also be able to communicate with catalog servers on
 the Net to search for documents which are not on the local system.")
-    (license lgpl2.1+)))
+    (license license:lgpl2.1+)))
 
 (define-public zeal
   (let ((commit "1cfa7c637f745be9d98777f06b4f8dec90892bf2")
@@ -425,4 +425,4 @@  (define-public zeal
       (synopsis "Offline documentation browser inspired by Dash")
       (description "Zeal is a simple offline documentation browser
 inspired by Dash.")
-      (license gpl3+))))
+      (license license:gpl3+))))