[bug#76746,v2,01/13] gnu: python-slugify: Update to 8.0.4.

Message ID 64a00324225b3aa51e8d4d034cdd1f8342037272.1741702571.git.45mg.writes@gmail.com
State New
Headers
Series [bug#76746,v2,01/13] gnu: python-slugify: Update to 8.0.4. |

Commit Message

45mg March 11, 2025, 2:23 p.m. UTC
  * gnu/packages/python-web.scm (python-slugify): Update to 8.0.4.
[source]: Fetch from GitHub, as PyPI archive no longer includes tests.

Change-Id: I0b30b800362694aeee545de736213ea939dbd24e
---
 gnu/packages/python-web.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ad02690b8d..0b0428485b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7093,13 +7093,16 @@  (define-public python-slowapi
 (define-public python-slugify
   (package
     (name "python-slugify")
-    (version "5.0.2")
+    (version "8.0.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "python-slugify" version))
+       (method git-fetch) ; no tests in PyPI
+       (uri (git-reference
+             (url "https://github.com/un33k/python-slugify")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1aww2ncglyii4jkbfjxqhinivawf9zmwifcj32d69gpwp6h86czi"))))
+        (base32 "0z83nwy7acc72mb2jv3516nfplah1wm61wkmnzl71dh8i4q985yd"))))
     (propagated-inputs
      (list python-unidecode python-text-unidecode))
     (arguments