diff mbox series

[bug#73184,1/5] gnu: Add go-github-com-tannerryan-ring.

Message ID 647461c70212e4fce554618fccf2b5e85cffa473.1726082409.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some Golang libraries from the "awesome-go" list | expand

Commit Message

Artyom V. Poptsov Sept. 11, 2024, 7:23 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-tannerryan-ring): New variable.

Change-Id: I14d280d6af0dd25ee8b2bd1a7565640223fdbe21
---
 gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c2059b7906..037cef32db 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6309,6 +6309,30 @@  (define-public go-github-com-syndtr-goleveldb
 storage system.")
     (license license:bsd-2)))
 
+(define-public go-github-com-tannerryan-ring
+  (package
+    (name "go-github-com-tannerryan-ring")
+    (version "1.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tannerryan/ring")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07q5qcg2wv696nnw3rrgc49mqijapdwp3xsscaxb5867bz79s841"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/tannerryan/ring"))
+    (home-page "https://github.com/tannerryan/ring")
+    (synopsis "High performance bloom filter")
+    (description
+     "@code{ring} provides a high performance and thread safe Go implementation of a
+@url{https://en.wikipedia.org/wiki/Bloom_filter, bloom filter}.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-teambition-rrule-go
   (package
     (name "go-github-com-teambition-rrule-go")