diff mbox series

[bug#42281] gnu: Add python-buku.

Message ID 640185039a38a8f421546d3b8b987f6d4cb4ec59.camel@zrythm.org
State Accepted
Headers show
Series [bug#42281] gnu: Add python-buku. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou July 8, 2020, 9:41 p.m. UTC
Forgot patch

Comments

Marius Bakke July 20, 2020, 10:29 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> * gnu/packages/python-xyz.scm (python-buku): New variable.

As this seems like a general-purpose tool and not a Python library, it
would be good to place this elsewhere.  I'm not sure where though, maybe
(gnu packages web)?

Also I think the 'python-' prefix can be removed.

[...]
  
> +(define-public python-buku
> +  (package
> +    (name "python-buku")
> +    (version "4.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "buku" version))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
> +    (build-system python-build-system)
> +    (arguments
> +      `(#:tests? #f)) ; needs python-mypy-extensions which fails to build

Actually python-mypy-extensions seems to not be in Guix at all.  Can you
adjust the comment with a TODO?

> +    (propagated-inputs
> +      `(("python-html5lib" ,python-html5lib)
> +        ("python-urllib3" ,python-urllib3)
> +        ("python-beautifulsoup4" ,python-beautifulsoup4)
> +        ("python-pytest" ,python-pytest)
> +        ("python-pytest-cov" ,python-pytest-cov)
> +        ("python-pylint" ,python-pylint)
> +        ("python-vcrpy" ,python-vcrpy)))

These can probably be regular inputs, as python-build-system will
automatically 'wrap' the executables with these on PYTHONPATH.

> +    (home-page "https://github.com/jarun/buku")
> +    (synopsis
> +      "Bookmark manager")
> +    (description
> +      "buku is a powerful bookmark manager written in Python3 and SQLite3.")

It's a chore, but it would be great if you could expand on the
description.  Something along the lines of "@command{buku} can
auto-import bookmarks from your browser and present them in an
interactive command-line interface that lets you compose and update
bookmarks directly.  It can also present them in a web interface with
@command{bukuserver}."

Can you send an updated patch?
diff mbox series

Patch

From b9dee307a164daac75874f85fe5192adc77fc505 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:37:25 +0100
Subject: [PATCH] gnu: Add python-buku.

* gnu/packages/python-xyz.scm (python-buku): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 98db6d9e51..e4b5cde95a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20261,6 +20261,36 @@  randomness (including real life dice) and different wordlists (including
 cryptographically signed ones).")
     (license license:gpl3+)))
 
+(define-public python-buku
+  (package
+    (name "python-buku")
+    (version "4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "buku" version))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:tests? #f)) ; needs python-mypy-extensions which fails to build
+    (propagated-inputs
+      `(("python-html5lib" ,python-html5lib)
+        ("python-urllib3" ,python-urllib3)
+        ("python-beautifulsoup4" ,python-beautifulsoup4)
+        ("python-pytest" ,python-pytest)
+        ("python-pytest-cov" ,python-pytest-cov)
+        ("python-pylint" ,python-pylint)
+        ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://github.com/jarun/buku")
+    (synopsis
+      "Bookmark manager")
+    (description
+      "buku is a powerful bookmark manager written in Python3 and SQLite3.")
+    (license license:gpl3+)))
+
 (define-public pyzo
   (package
     (name "pyzo")
-- 
2.27.0