diff mbox series

[bug#60976,3/3] gnu: Add ditaa

Message ID 63d2b66d.a70a0220.ecd70.18ac@mx.google.com
State New
Headers show
Series [bug#60976,1/3] gnu: Add java-jericho-html | expand

Commit Message

Frank Pursel Jan. 26, 2023, 5:01 p.m. UTC
---
 gnu/packages/ditaa.scm | 145 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 145 insertions(+)
 create mode 100644 gnu/packages/ditaa.scm
diff mbox series

Patch

diff --git a/gnu/packages/ditaa.scm b/gnu/packages/ditaa.scm
new file mode 100644
index 0000000000..e1f063e179
--- /dev/null
+++ b/gnu/packages/ditaa.scm
@@ -0,0 +1,145 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+;;;
+;;; Copyright © 2023 Frank Pursel <frank.pursel@gmail.com>
+;;;
+
+(define-module (gnu packages ditaa)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages bash)
+  #:use-module (gnu packages batik)
+  #:use-module (gnu packages java)
+  #:use-module (gnu packages java-xml)
+  #:use-module (gnu packages xml)
+  #:use-module (guix build-system ant)
+  #:use-module (guix build utils)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix modules)
+ )
+
+(define-public ditaa
+  (package
+    (name "ditaa")
+    (version "0.11.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/stathissideris/ditaa")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1y3g17wp1wvb05m56pp25avww2njpgh0gk0jsbsf25scj7hyyj26"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (format #t "~%~a~%" "Finding and removing sourced jars.")
+                  (for-each
+                   (lambda (jarf)
+                     (delete-file jarf)
+                     (format #t "Deleted: ~a~%" jarf))
+                   (find-files "." "\\.jar$"))))))
+    (build-system ant-build-system)
+    (inputs (list bash-minimal))
+    (native-inputs (list java-libbatik java-commons-cli java-w3c-svg
+                         java-jericho-html `(,icedtea "jdk") java-junit))
+    (arguments
+     `(#:build-target "release-all"
+       #:phases
+       (modify-phases %standard-phases
+           ;; Ant's buildfile and build tree need to be modified
+           ;; to provide access to the guix builds of the
+           ;; batik and the java-commons-cli
+           ;; jar files.  Also some of the source requires java7.
+           (add-before 'build 'build-prep
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let* ((batik-jar (search-input-file inputs
+                                                    "share/java/batik.jar"))
+                      (commons-cli-jar (search-input-file inputs
+                                                          "lib/m2/commons-cli/commons-cli/1.4/commons-cli-1.4.jar")))
+                 (mkdir-p "lib")
+                 (copy-file batik-jar "./lib/batik.jar")
+                 (copy-file commons-cli-jar "./lib/commons-cli.jar"))
+               (with-directory-excursion "build"
+                 (substitute* "release.xml"
+                   (("source=\"1.6\"")
+                    "source=\"7\"")
+                   (("<file name=\"commons-cli-1.2.jar\"/>")
+                    (string-append "<file name=\"commons-cli.jar\"/>"
+                                   "\n" "<file name=\"batik.jar\"/>"))))
+               #t))
+           (replace 'build
+             (lambda* _
+               (setenv "ANT_OPTS"
+                       (string-append "-Dversion.string="
+                                      ,version))
+               (with-directory-excursion "build"
+                 (invoke "ant" "-f" "release.xml" "release-jar")) #t))
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (if tests?
+                   (begin
+                     (setenv "ANT_OPTS"
+                             (string-append "-Dversion.string="
+                                            ,version))
+                     (mkdir-p "tests/testlib")
+                     (with-directory-excursion "build"
+                       (invoke "ant" "-f" "release.xml"
+                               "generate-test-images")
+                       (invoke "ant" "test"))) #f)))
+           (replace 'install
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (lib (string-append out "/lib"))
+                      (bin (string-append out "/bin"))
+                      (bash (search-input-file inputs "bin/bash"))
+                      (java (search-input-file inputs "bin/java"))
+                      (jre (search-input-directory inputs "jre"))
+                      (ditaa (string-append out "/bin/ditaa"))
+                      (jar-name (string-append ,name
+                                               ,version ".jar")))
+                 (with-directory-excursion "releases"
+                   (install-file jar-name lib))
+                 (mkdir-p bin)
+                 (with-output-to-file ditaa
+                   (lambda _
+                     (format #t "#!~a~%JAVA_HOME=~a ~a -jar ~a/~a $@~%"
+                             bash jre java lib jar-name)))
+                 (chmod ditaa #o755)) #t))
+           (add-after 'install 'install-docs
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((doc (string-append (assoc-ref outputs "out")
+                                         "/share/doc/")))
+                 (for-each (lambda (filen)
+                             (install-file filen doc))
+                           (find-files "." ".*README\\.md"))) #t)))))
+    (home-page "https://github.com/stathissideris/ditaa")
+    (synopsis "Create graphics from ascii art")
+    (description
+     "ditaa is a small command-line utility 
+that converts diagrams drawn using ascii art 
+('drawings' that contain characters that resemble lines like | / - ), 
+into proper bitmap graphics.")
+    (license license:lgpl3)))
+
+
+
+
+