diff mbox series

[bug#64973,python-team,1/1] gnu: python-attrs: Update to 23.1.0.

Message ID 636e72617cfcd22217c9c7e318cb0ed3fafe12eb.1690806956.git.hako@ultrarare.space
State New
Headers show
Series gnu: python-attrs: Update to 23.1.0. | expand

Commit Message

Hilton Chain July 31, 2023, 1:04 p.m. UTC
* gnu/packages/python-xyz.scm (python-attrs): Update to 23.1.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Remove field.
[native-inputs]: Add python-hatchling, python-hatch-fancy-pypi-readme,
python-hatch-vcs.
Remove python-coverage, python-hypothesis, python-pympler, python-six.
(python-attrs-bootstrap)[native-input]: Adjust accordingly.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++------------------
 1 file changed, 10 insertions(+), 18 deletions(-)

Comments

jgart Sept. 8, 2023, 5:22 a.m. UTC | #1
Thanks, applied to the python-team branch.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a3daf51c6..59f1686b14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21411,29 +21411,19 @@  (define-public python-attrdict3
 (define-public python-attrs
   (package
     (name "python-attrs")
-    (version "21.2.0")
+    (version "23.1.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "attrs" version))
               (sha256
                (base32
-                "1yzmwi5d197p0qhl7rl4xi9q1w8mk9i3zn6hrl22knbcrb1slspg"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'remove-test-hypothesis-deadlines
-                    (lambda _
-                      (substitute* "tests/test_make.py"
-                        (("assume, given") "assume, given, settings")
-                        (("( +)@given" all spaces)
-                         (string-append spaces "@settings(deadline=None)\n" all)))))
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest")))))))
+                "05g0a3y9hv74zblgf51zd0ar3g1ksfngjdgj3dps44qmb1nq6yb2"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-hypothesis python-pympler python-pytest
-           python-six))
+     (list python-hatchling
+           python-hatch-fancy-pypi-readme
+           python-hatch-vcs
+           python-pytest))
     (home-page "https://github.com/python-attrs/attrs/")
     (synopsis "Attributes without boilerplate")
     (description "@code{attrs} is a Python package with class decorators that
@@ -21445,7 +21435,9 @@  (define-public python-attrs-bootstrap
   (package
     (inherit python-attrs)
     (name "python-attrs-bootstrap")
-    (native-inputs `())
+    (native-inputs
+     (modify-inputs (package-native-inputs python-attrs)
+       (delete "python-pytest")))
     (arguments `(#:tests? #f))))
 
 (define-public python-cliapp