diff mbox series

[bug#63044,v3] gnu: python-setuptools: Disable date checking in bdist_egg.py

Message ID 6351ec19a1f494f5ae5d9828530f70f9c1aa2dea.1682690472.git.bjc@spork.org
State New
Headers show
Series [bug#63044,v3] gnu: python-setuptools: Disable date checking in bdist_egg.py | expand

Commit Message

Brian Cully April 28, 2023, 2:01 p.m. UTC
This fixes errors when packing Python eggs, where ZipFile fails due to Guix
setting file timestamps to 0 epoch seconds, where ZipFile wants all files to
date from at least 1980.

* gnu/packages/python-build.scm (python-setuptools)
[disable-zipfile-date-check]:  new phase
---
 gnu/packages/python-build.scm | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 70719c44d4..d9f6f5beff 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -299,7 +299,21 @@  (define-public python-setuptools
     (build-system python-build-system)
     ;; FIXME: Tests require pytest, which itself relies on setuptools.
     ;; One could bootstrap with an internal untested setuptools.
-    (arguments (list #:tests? #f))
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Disable the check which requires files to be dated from at least
+          ;; 1980.
+          ;;
+          ;; This phase is also in the base python package, as it includes its
+          ;; own setuptools.
+          (add-after 'unpack 'disable-zipfile-date-check
+            (lambda _
+              (substitute* "setuptools/command/bdist_egg.py"
+                (("zipfile.ZipFile\\(zip_filename, mode, compression=compression\\)")
+                 "zipfile.ZipFile(zip_filename, mode, compression=compression, strict_timestamps=False)")))))))
     (home-page "https://pypi.org/project/setuptools/")
     (synopsis "Library designed to facilitate packaging Python projects")
     (description "Setuptools is a fully-featured, stable library designed to