diff mbox series

[bug#72107,2/5] gnu: Add ocaml-thread-table.

Message ID 62b3c0488e059e026271c2ef4c88fa8aa3e5d00f.1720956786.git.benjamin@uvy.fr
State New
Headers show
Series gnu: ocaml-eio: Update to 0.12. | expand

Commit Message

Benjamin July 14, 2024, 11:49 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-thread-table): New variable.

Change-Id: If0175f44e6959befc539a399bd8bdebdcb41ba1b
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fa84ea73a5..a6fb5af138 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3133,6 +3133,29 @@  (define-public ocaml-hmap
 to which allows adding and looking up bindings in a type safe manner.")
     (license license:isc)))
 
+(define-public ocaml-thread-table
+  (package
+    (name "ocaml-thread-table")
+    (version "1.0.0")
+    (home-page "https://github.com/ocaml-multicore/thread-table")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256 (base32
+                "05sla96m4lbfrnrjczj4xl1zbcwypir6krp4y16x50hz24ai12pc"))))
+    (build-system dune-build-system)
+    (arguments `(#:package "thread-table"))
+    (native-inputs (list ocaml-odoc ocaml-alcotest))
+    (synopsis "A lock-free thread-safe integer keyed hash table")
+    (description "Ocaml library implementing a minimalist lock-free thread-safe
+integer keyed hash table with zero synchronization overhead on lookups designed
+for associating thread specific state with threads within a domain.")
+    (license license:isc)))
+
 (define ocaml-eio
   (package
     (name "ocaml-eio")